Triangle LOVE
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 4875 Accepted Submission(s): 1923
Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
Take the sample output for more details.
Sample Input
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
Sample Output
Case #1: Yes Case #2: No
就像题目名字一样,给出一张图,问有没有三角恋关系,也就是有无成环。。
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdio>
using namespace std;
char ma1[2221][2221];
int inde[2222];
int flag;
int ans[11111];int n,m;
bool tapu()
{
int i,j;
for(i=0;i<n;i++)
for(j=0;j<n;j++)
{
if(inde[j]==0)
{
inde[j]=-1;
ans[i]=j;
for(int s=0;s<n;s++)
{
if(ma1[j][s]=='1')
inde[s]--;
}
break;
}
if(j==n-1)
{
return 0;
}
}
return 1;
}
int main()
{
int T;
cin>>T;
int case1=0;
while(T--)
{
case1++;
cin>>n;
int i,j,k;
flag=1;int a,b;
memset(ma1,0,sizeof(ma1));
memset(inde,0,sizeof(inde));
for(i=0;i<n;i++)
{
scanf("%s",&ma1[i]);
for(int s=0;s<n;s++)
if(ma1[i][s]=='1')
inde[s]++;
}
cout<<"Case #"<<case1<<": ";
if(tapu())
{
cout<<"No"<<endl;
}
else cout<<"Yes"<<endl;
}
return 0;
}