Problem A

本文介绍了一个经典的图论问题——寻找使所有节点相连的最小生成树,并通过Prim算法实现这一目标。文章提供了完整的代码示例,解释了如何通过迭代选择最短边来构建最小生成树。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. <br><br>We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.<br>
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.<br><br>Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.<br>
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. <br>
 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
简单题意:
  现在有N个村子,编号为1-N,需要建立公路使得每两个村子可以相互连通。现在给出一个各个村子之间的距离地图,以及已经连接的村子的编号。现在需要编写一个程序,求出使得任意两个村子可以连通的所修建的最短的公路距离。
解题思路形成过程;
  和老师课堂上讲的算法有异曲同工之处,课堂上的是求出最小连通图,而本题是求出最小生成树。但是,为了求出最短距离,就少了一部分代码。所以,用上数据结构中的Prim算法,求出最小生成树,然后解决问题。
感想:
  图这一个专题感觉会比以往难写算法。只有见得多了,才可以运用已知求出未知。
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=110;
const int INF=0x3f3f3f3f;
int n,ans;
int map[N][N],dis[N],vis[N];
void Prim()
{
    int i;
    for(i=1;i<=n;i++)
    {
        dis[i]=map[1][i];
        vis[i]=0;
    }
    dis[1]=0;
    vis[1]=1;
    int j,k,tmp;
    for(i=1;i<=n;i++){
        tmp=INF;
        for(j=1;j<=n;j++)
            if(!vis[j] && tmp>dis[j]){
                k=j;
                tmp=dis[j];
            }
        if(tmp==INF)
            break;
        vis[k]=1;
        ans+=dis[k];
        for(j=1;j<=n;j++)
            if(!vis[j] && dis[j]>map[k][j])
                dis[j]=map[k][j];
    }
}
int main()
{
    while(~scanf("%d",&n))
        {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&map[i][j]);
        int q,a,b;
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d%d",&a,&b);
            map[a][b]=map[b][a]=0;
        }
        ans=0;
        Prim();
        printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值