Problem C

本文介绍了一款名为“Super Jumping”的棋盘游戏,并详细解析了如何通过动态规划算法来找出玩家能够获得的最大得分路径。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.<br><br><center><img src=/data/images/1087-1.jpg></center><br><br>The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.<br>Your task is to output the maximum value according to the given chessmen list.<br>
 

Input
Input contains multiple test cases. Each test case is described in a line as follow:<br>N value_1 value_2 …value_N <br>It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.<br>A test case starting with 0 terminates the input and this test case is not to be processed.<br>
 

Output
For each case, print the maximum according to rules, and one line one case.<br>
 

Sample Input
  
  
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
 

Sample Output
4
10
3

简单题意:
  一项下棋的游戏,可以由两个或以上的玩家开始,每个棋子都是又一个正整数构成,也可以就看成终点或起点。玩家从出发点跳进终点,但有一项规则,就是只能从小的向大的棋子跳,并且玩家不能后退。可以跳过一个棋子,同样也可以跳过多个棋子,也可以直接从起点跳到终点,但是分数就为0了。现在。要求编写一个程序,求出能获得最大分数的跳棋子的方案。
解题思路形成过程:
  有难度的动态规划题目,关键在于题意的理解。 sum[i]=num[i]+sum[j],状态方程。所以只需要比较当前的sum[i]是否比其小,如果小的话,把值给当前棋子。最后就能得出最大的分数。
感想:
  题意读了好几遍才弄明白一点。动态规划的核心还是不会消失的,所以一步一步就能写出状态方程。
AC代码:
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
    int n,sum[1001],num[1001];
    while(cin>>n&&n!=0)
    {
        for(int i=1;i<=n;i++)
            cin>>num[i];
        sum[1]=num[1];
        int ans=sum[1];
        for(int i=2;i<=n;i++)
        {
            sum[i]=num[i];
            for(int j=1;j<i;j++)
            {
                if(num[j]<num[i]&&sum[j]+num[i]>sum[i])
                    sum[i]=num[i]+sum[j];
            }
            if(ans<sum[i])
                ans=sum[i];
        }
        cout<<ans<<endl;
    }
    return 0;
}
标题Python网络课程在线学习平台研究AI更换标题第1章引言介绍Python网络课程在线学习平台的研究背景、意义、国内外现状和研究方法。1.1研究背景与意义阐述Python在线学习平台的重要性和研究意义。1.2国内外研究现状概述国内外Python在线学习平台的发展现状。1.3研究方法与论文结构介绍本文的研究方法和整体论文结构。第2章相关理论总结在线学习平台及Python教育的相关理论。2.1在线学习平台概述介绍在线学习平台的基本概念、特点和发展趋势。2.2Python教育理论阐述Python语言教学的理论和方法。2.3技术支持理论讨论构建在线学习平台所需的技术支持理论。第3章Python网络课程在线学习平台设计详细介绍Python网络课程在线学习平台的设计方案。3.1平台功能设计阐述平台的核心功能,如课程管理、用户管理、学习跟踪等。3.2平台架构设计给出平台的整体架构,包括前后端设计、数据库设计等。3.3平台界面设计介绍平台的用户界面设计,强调用户体验和易用性。第4章平台实现与测试详细阐述Python网络课程在线学习平台的实现过程和测试方法。4.1平台实现介绍平台的开发环境、技术栈和实现细节。4.2平台测试对平台进行功能测试、性能测试和安全测试,确保平台稳定可靠。第5章平台应用与效果分析分析Python网络课程在线学习平台在实际应用中的效果。5.1平台应用案例介绍平台在实际教学或培训中的应用案例。5.2效果评估与分析通过数据分析和用户反馈,评估平台的应用效果。第6章结论与展望总结Python网络课程在线学习平台的研究成果,并展望未来发展方向。6.1研究结论概括本文关于Python在线学习平台的研究结论。6.2研究展望提出未来Python在线学习平台的研究方向和发展建议。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值