POJ 3069 Saruman's Army

解决Saruman'sArmy问题,通过贪心算法确定最少标记点数,确保每个点在其有效范围内至少有一个标记点。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


一道足足做了三天(当然其中还穿插着别的半成品555)的题。


Saruman's Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10006 Accepted: 5034

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

题目大意:在一个数轴上有N个点,现要在这N个点其中挑选一些点加上标记,要求所有有标记的点的R范围以内能包含所有点(换言之,对于每一个点,在它的R范围之内必须有一个被标记的点),求最少需要标记多少点。


思路:一上来感觉也看不出是个什么算法,但是画个图(高手请忽略此步骤)可以发现, 有一些只有傻子才会做的操作:标记最左面或者最右面的点。不难看出这样会浪费距离,而且再一想每一个点都必须被包含所以完全可以线性顺次标记,所以很自然的想到贪心,代码附上。


#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<cstdlib>
#include<ctime>

using namespace std;

const int MAXN=1010;

void work(int r,int n)
{
	int x[MAXN];
	int i;
	
	for (i=0;i<n;i++)
	{
		scanf("%d",&x[i]);
	}
	sort(x,x+n);
	int ans=0;
	i=0; 
	while (i<n)
	{
		int s=x[i++];
		while (i<n && x[i]<=s+r)
		{
			i++;
		}
		int p=x[i-1];
		while (i<n && x[i]<=p+r)
		{
			i++;
		}
		ans++;
	}
	printf("%d\n",ans);
}

int main()
{
	int a,b;
	scanf("%d%d",&a,&b);
	while (a!=-1 && b!=-1)
	{
		work(a,b);
		scanf("%d%d",&a,&b);
	}
    return 0;
}

这次数组下标从0开始!此处s是没有被覆盖的最左边的点的位置,p是每一次新加的点的位置。注意while循环中i<n,没有等号!!博主在这个地方提供了一次分母。。。


要加速了不然没法每天一题了233。

WebSocket是一种在客户端和服务器之间建立持久连接的协议,它允许双方进行双向通信,极大地提高了实时性,被广泛应用于即时通讯、在线游戏、股票交易等领域。本篇将详细讲解如何使用C#来实现WebSocket,以及Fleck库在其中的作用。 WebSocket协议基于HTTP的握手过程,但一旦连接建立,它就不再依赖HTTP,而是通过TCP直接通信。在C#中,我们可以利用.NET Framework或.NET Core提供的System.Net.WebSockets命名空间来创建WebSocket服务器和客户端。然而,对于更高级的功能和更好的灵活性,开发者通常会选择第三方库,如Fleck。 Fleck是C#中一个轻量级且高效的WebSocket服务器实现。它提供了丰富的事件驱动API,使得开发者可以轻松地处理WebSocket连接的建立、消息传递和断开等操作。下面我们将探讨Fleck的使用步骤: 1. **安装Fleck**:你需要在你的项目中添加Fleck库。如果你使用的是NuGet包管理器,可以通过搜索"Fleck"并安装来获取。 2. **初始化服务器**:在C#代码中,首先创建一个Fleck服务器实例,指定监听的IP地址和端口号。例如: ```csharp var server = new Fleck.WebSocketServer("ws://localhost:8080"); ``` 3. **配置服务器**:你可以设置各种配置选项,如最大接收/发送缓冲区大小、心跳间隔等。然后注册事件处理器,如OnOpen、OnClose、OnMessage等,以处理客户端连接、断开和消息接收。 4. **连接事件**:`OnOpen`事件在客户端连接时触发,你可以在这里对新连接进行初始化操作,如存储连接信息、验证用户等。 5. **消息处理**:`OnMessage`
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值