(*)[kuangbin带你飞]专题二 搜索进阶 H-Gap(bfs+hash)

本文介绍了一款名为Gap的卡片游戏及其求解算法。游戏目标是通过移动卡片形成四组同花顺。采用BFS算法搜索最优解,并利用哈希表进行状态存储以避免重复搜索。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

H - Gap


Let's play a card game called Gap. 

You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card. 

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout. 

Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: "11" to the top row, "21" to the next, and so on. 

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout. 

At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of "42" is "43", and "27" has no successor. 

In the above layout, you can move "43" to the gap at the right of "42", or "36" to the gap at the right of "35". If you move "43", a new gap is generated to the right of "16". You cannot move any card to the right of a card of value 7, nor to the right of a gap. 

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows. 


Your task is to find the minimum number of moves to reach the goal layout. 
Input
The input starts with a line containing the number of initial layouts that follow. 


Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards. 
Output
For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce "-1". 
Sample Input
4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31
Sample Output
0
33
60

-1

题意:给一张打乱的图,按规则移动回排列整齐的样子。

思路:bfs,其它没什么好说的,主要是判重那里想不到什么好方法,又不想太暴力。第一,可以存成把图存成string类型,然后用map映射;第二,hash表。

目前hash还是没有搞太懂,可能因为方法太多了,感觉很乱。。

代码:

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
#define IO ios::sync_with_stdio(false);cin.tie(0);
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;
int n, vis[1000010]; 
int b[4][7]={11, 12, 13, 14, 15, 16, 17,
			 21, 22, 23, 24, 25, 26, 27,
			 31, 32, 33, 34, 35, 36, 37,
			 41, 42, 43, 44, 45, 46, 47};
typedef struct {
	int a[10][10];
	int x[10], y[10];
	int step;
}Node;
Node node;
unsigned int gethash(Node p)
{
    unsigned int hash=0 ;
    int i ,j;
    for(i=0;i<4;i++)
    {
    	for(j = 0; j <= 7; j++)
        if((i&1)==0)
        {
            hash^=((hash<<7)^(p.a[i][j])^(hash>>3));
        }
        else
        {
            hash^=(~((hash<<11)^(p.a[i][j])^(hash>>5)));
        }
    }
       
    return(hash %1000007);
}
int panduan2(Node p)
{
	for(int i = 0; i < 4; i++){
		for(int j = 0; j < 7; j++){
			if(p.a[i][j] != b[i][j])
				return 0;
		}
	}
	return 1;
}
void bfs()
{
	queue<Node> q;
	node.step = 0;
	q.push(node);
	while(!q.empty()){
		Node t=q.front(), p;

		if(panduan2(t)){
			cout << t.step << endl;
			break;
		} 
		for(int k = 0; k < 4; k++){
			for(int i = 0; i < 4; i++){
				for(int j = 0; j <= 7; j++){
					if(t.a[i][j] == t.a[t.x[k]][t.y[k]-1]+1){
						p=t;
						swap(p.a[i][j], p.a[t.x[k]][t.y[k]]);
						p.x[k] = i; p.y[k] = j;
						p.step = t.step+1;
						if(!vis[gethash(p)]){
							vis[gethash(p)]=1;
							q.push(p);
						}
					}
				}
			}
		} 
		q.pop();
	}
	if(q.empty()){
		cout << "-1" << endl;
	}
}
int main()
{
	cin >> n;
	while(n--){
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < 4; i++){
			for(int j = 1; j <= 7; j++){
				cin >> node.a[i][j];
				if(node.a[i][j] == 11){
					node.a[i][j] = 0;node.a[0][0] = 11;
					node.x[0] = i;node.y[0] = j;
				}
				if(node.a[i][j] == 21){
					node.a[i][j] = 0;node.a[1][0] = 21;
					node.x[1] = i;node.y[1] = j;
				}
				if(node.a[i][j] == 31){
					node.a[i][j] = 0;node.a[2][0] = 31;
					node.x[2] = i;node.y[2] = j;
				}
				if(node.a[i][j] == 41){
					node.a[i][j] = 0;node.a[3][0] = 41;
					node.x[3] = i;node.y[3] = j;
				}
			} 
		}
		bfs();
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值