B - FatMouse's Speed

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],…, m[n] then it must be the case that

W[m[1]] < W[m[2]] < … < W[m[n]]

and

S[m[1]] > S[m[2]] > … > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output
4
4
5
9
7

题意:求体重递增速度递减的最长序列。

用dp[i]记录在第i只老鼠的所在序列的最长长度,注意逆向输出(可以递归,也可以入栈)。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n,m;
int pre[1005];
struct q
{
    int id;
    int w;
    int s;
}mice[1005];
struct p
{
    int minn;
    int num;
}dp[1005];
int mark[1005][1005];
bool cmp(q a,q b)
{
    return a.w<b.w;
}
bool cmp1(p a,p b)
{
    return a.num<b.num;
}
void print(int a)
{
    if(pre[a]==0)
        printf("%d\n",mice[a].id);
    else
    {
        print(pre[a]);
        printf("%d\n",mice[a].id);

    }
}//逆向输出
int main (void)
{
        int ww,ss,t=1;
        while(~scanf("%d %d",&ww,&ss))
        {
            //if(ww==0&&ss==0)
            //  break;
            mice[t].w=ww;
            mice[t].s=ss;
            mice[t].id=t;   
            //printf("%d %d\n",mice[t].w,mice[t].s);
            t++;
        }
        memset(pre,0,sizeof(pre));
        sort(mice+1,mice+t,cmp);
        //dp[1].minn=0;
        m=0;
        for(int i=1;i<t;i++)
        {
            dp[i].num=1;
            //初始化每只老鼠都是自己的一个序列,长度为1
        }
        int x;
        int cnt=0;
        int j;
        for(int i=1;i<t;i++)//遍历i只老鼠
        {
            for(j=1;j<t;j++)
            {       
                if(mice[i].w==mice[j].w)//如果i老鼠和j老鼠体重一样
                    break;
                if(mice[i].s<mice[j].s)//否则
                {
                    if(dp[i].num<dp[j].num+1)//如果当前序列比较短
                    {
                    dp[i].num=dp[j].num+1;
                    //dp[i].minn=mice[i].s;
                    //dp[i].num++;
                    pre[i]=j;
                    //记录这只老鼠,表示i老鼠能被j老鼠更新
                    }
                }
            }
        }
        int maxid=1;
        for(int i=1;i<t;i++)
        {
            if(dp[maxid].num<dp[i].num)
                maxid=i;
        }
        printf("%d\n",dp[maxid].num);
        print(maxid);
        //sort(dp+1,dp+t+1,cmp1);
    return 0;
}

还有入栈逆向输出:

stack <int> st;
        int mm=maxid;
        while(mm!=0)
        {
            st.push(mm);
            mm=pre[mm];
        }
        while(!st.empty())
        {
            printf("%d\n",mice[st.top()].id);
            st.pop();
        }
《餐馆点餐管理系统——基于Java和MySQL的课程设计解析》 在信息技术日益发达的今天,餐饮行业的数字化管理已经成为一种趋势。本次课程设计的主题是“餐馆点餐管理系统”,它结合了编程语言Java和数据库管理系统MySQL,旨在帮助初学者理解如何构建一个实际的、具有基本功能的餐饮管理软件。下面,我们将深入探讨这个系统的实现细节及其所涉及的关键知识点。 我们要关注的是数据库设计。在“res_db.sql”文件中,我们可以看到数据库的结构,可能包括菜品表、订单表、顾客信息表等。在MySQL中,我们需要创建这些表格并定义相应的字段,如菜品ID、名称、价格、库存等。此外,还要设置主键、外键来保证数据的一致性和完整性。例如,菜品ID作为主键,确保每个菜品的唯一性;订单表中的顾客ID和菜品ID则作为外键,与顾客信息表和菜品表关联,形成数据间的联系。 接下来,我们来看Java部分。在这个系统中,Java主要负责前端界面的展示和后端逻辑的处理。使用Java Swing或JavaFX库可以创建用户友好的图形用户界面(GUI),让顾客能够方便地浏览菜单、下单。同时,Java还负责与MySQL数据库进行交互,通过JDBC(Java Database Connectivity)API实现数据的增删查改操作。在程序中,我们需要编写SQL语句,比如INSERT用于添加新的菜品信息,SELECT用于查询所有菜品,UPDATE用于更新菜品的价格,DELETE用于删除不再提供的菜品。 在系统设计中,我们还需要考虑一些关键功能的实现。例如,“新增菜品和价格”的功能,需要用户输入菜品信息,然后通过Java程序将这些信息存储到数据库中。在显示所有菜品的功能上,程序需要从数据库获取所有菜品数据,然后在界面上动态生成列表或者表格展示。同时,为了提高用户体验,可能还需要实现搜索和排序功能,允许用户根据菜品名称或价格进行筛选。 另外,安全性也是系统设计的重要一环。在连接数据库时,要避免SQL注入攻击,可以通过预编译的PreparedStatement对象来执行SQL命令。对于用户输入的数据,需要进行验证和过滤,防止非法字符和异常值。 这个“餐馆点餐管理系统”项目涵盖了Java编程、数据库设计与管理、用户界面设计等多个方面,是一个很好的学习实践平台。通过这个项目,初学者不仅可以提升编程技能,还能对数据库管理和软件工程有更深入的理解。在实际开发过程中,还会遇到调试、测试、优化等挑战,这些都是成长为专业开发者不可或缺的经验积累
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值