A character string is said to have period k if it can be formed by concatenating one or more repetitions
of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed
by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one
repetition of ”abcabcabcabc”).
Write a program to read a character string and determine its smallest period.
Input
The first line oif the input file will contain a single integer N indicating how many test case that your
program will test followed by a blank line. Each test case will contain a single character string of up
to 80 non-blank characters. Two consecutive input will separated by a blank line.
Output
An integer denoting the smallest period of the input string for each input. Two consecutive output are
separated by a blank line.
Sample Input
1
HoHoHo
Sample Output
2
#include<stdio.h>
#include<string.h>
#define max 81
int main()
{
int n,i,j;
char s[max];
scanf("%d",&n);
while(n--)
{
scanf("%s",s);
int l=strlen(s);
for(i=1;i<=l;i++)
{
if(l%i==0)
{
for(j=i;j<l;++j)
{
if(s[j]!=s[j%i])
break;
}
if(j==l)
{
printf("%d",i);
break;
}
}
}
}
}