PAT甲级1001 A+B Format

题目地址:编程题 - PAT (Advanced Level) Practice (pintia.cn)

介绍

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

 输入样例

input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

输出样例

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

代码

	#include<bits/stdc++.h>
	using namespace std;
	#define ll long long  
	#define ull unsigned long long
	
	void solve() {
		ll a,b;
		cin>>a>>b;
		a=a+b;
		
		int c=0,d=0;
		if(a<0)
		{
			cout<<"-"; 
		 } 
		 a=abs(a);
		 b=a;
		 /*for(int i=0;;i++)
		 {
		 	if(b>=1000)
		 	{
		 		b/=1000;
			 }
		 }*/
		 string ssr=to_string(a);
		 d=ssr.length();
		 if(d<=3)
		 {
		 	cout<<a;
		 }
		 else
		 {
		 	a=d%3;
		 	for(c=0;c<=a-1;c++)
		 	{
		 		cout<<ssr[c];
		 	}
		 	for(c=a;c<=ssr.length()-1;c++)
		 	{
		 		if((c-a)%3==0&&c!=0&&c!=ssr.length()-1)
		 		{
		 			cout<<",";
				 }
				 cout<<ssr[c];
			}
		 }
		 
	}
	signed main() {
	    ios::sync_with_stdio(0);
	    cout.tie(0);
	    cin.tie(0);
	
	    ll t = 1; 
	    // std::cin >> t;
	    while (t--) {
	        solve();
	    }
	}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值