Triangular Pastures
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 6475 | Accepted: 2108 |
Description
Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite.
I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length.
Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments.
I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length.
Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments.
Input
* Line 1: A single integer N
* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique.
* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique.
Output
A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed.
Sample Input
5 1 1 3 3 4
Sample Output
692
Hint
[which is 100x the area of an equilateral triangle with side length 4]
Source
题意:给n个棍,每个棍都有长度,求用这n个棍能摆成的最大三角形面积。
二维01背包 dp[i][j]表示两边分别为i和j的状态是否可达,这里i>=j,避免重复浪费空间,面积用海伦公式求,求的过程中要用double存,状态转移在代码中了
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
bool dp[805][805];
int a[41],sum;
int area(int i,int j,int k)
{
double p=sum/2.0;
return int(sqrt(p*(p-i)*(p-j)*(p-k))*100);
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF){
int ans=-1;
sum=0;
for(int i=1;i<=n;i++){
scanf("%d",&a[i]);
sum+=a[i];
}
int m=(sum+1)/2;
memset(dp,0,sizeof(dp));
dp[0][0]=1;
for(int i=1;i<=n;i++)
for(int j=m;j>=0;j--)
for(int k=j;k>=0;k--)
if(dp[j][k])dp[j+a[i]][k]=dp[j][k+a[i]]=1;
for(int j=m;j>=0;j--)
for(int k=j;k>=0;k--)
if(dp[j][k])ans=max(ans,area(j,k,sum-j-k));
printf("%d\n",ans);
}
return 0;
}