Zipper(拉链)

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 
 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

这一题单看案例也能明白一二。给出3个字符串,判断后者是不是由前者组成的,不过要按顺序。

一般时候我们都会立即用for循环一个一个对比,但是确实是不对的,因为两者会有相同的字符,不能判断是否要先写哪一个。

 这一题我没敢往搜索上想,因为我广搜不太好,遇到一个题就可能往深搜上写,现在已经不太敢用深搜了;

当然这道题有别的做法,不过深搜容易写,也容易理解。

每次将已经比较过的下标标记起来,使搜索结束的更快一些。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
char a[220],b[220],c[440],vir[220][220];
int la,lb,lc;
using namespace std;
int flag;
void dfs(int x,int y,int z)
{
	if(vir[x][y])
	 return ;
	if(z==lc)
	{
		flag=1;
		return ;
	}
	vir[x][y]=1;
	if(a[x]==c[z])
	dfs(x+1,y,z+1);
	if(b[y]==c[z])
	dfs(x,y+1,z+1);
}
int main()
{
	int t,w=1;
	scanf("%d",&t);
	while(t--)
	{
		memset(vir,0,sizeof(vir));
		flag=0;
		scanf("%s %s %s",a,b,c);
	    la=strlen(a);
	    lb=strlen(b);
	    lc=strlen(c);
	    dfs(0,0,0);
	    printf("Data set %d: ",w++);
	    if(flag==1)
		printf("yes\n");
		else
		printf("no\n");  
	}
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值