**HDU1847-畅通工程续
Problem Description**
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。
现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1
Author
linle
Source
2008浙大研究生复试热身赛(2)——全真模拟
AC代码
#include <bits/stdc++.h>
using namespace std;
#define ll long long
const int INF = 0x3f3f3f3f;
const int maxn=2e3+10;
int N,M;
int mapp[maxn][maxn];
void Floyd()
{
for(int k=0; k<N; k++)//Floyd算法的核心
{
for(int i=0; i<N; i++)
{
for(int j=0; j<N; j++)
{
if((mapp[i][k]+mapp[k][j])<mapp[i][j])
{
mapp[i][j]=mapp[i][k]+mapp[k][j];
}
}
}
}
}
int main()
{
while(scanf("%d%d",&N,&M)!=EOF)
{
for(int i=0; i<N; i++)
{
for(int j=0; j<N; j++)
{
if(i==j)
{
mapp[i][j]=0;
}
else
{
mapp[i][j]=INF;
}
}
}
for(int i=1; i<=M; i++)
{
int A,B,X;
cin>>A>>B>>X;
if(X<mapp[A][B])//wa点,题目的数据可能会重复,选择最短的路径
{
mapp[A][B]=X;
mapp[B][A]=X;
}
}
int S,T;
cin>>S>>T;
Floyd();
if(mapp[S][T]==INF)
{
cout<<"-1"<<endl;
}
else
{
cout<<mapp[S][T]<<endl;
}
}
return 0;
}