Lowest Bit

题目描述

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.  

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
 
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

输入

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

输出

For each A in the input, output a line containing only its lowest bit.

示例输入

26
88
0

示例输出

2
8

#include<stdio.h>
#include<string.h>
#include<math.h>
#define N 1010
int main()
{
    int n,i;
    while(~scanf("%d",&n))
    {
      if(n==0)
      {
       break;
      }
      else
      {
         int t=0;
         while(n%2==0)
         {
           t++;
           n=n/2;
         }
         printf("%d\n",(int)pow(2,t));//表示2的n次方
      }
    }



  return 0;
}




我参考了最新的maix API路径,请帮我改出可行的完整代码我查了官方API文档,在帮我完善一次完整代码 enum Format { FMT_RGB888 = 0, // RGBRGB…RGB, R at the lowest address FMT_BGR888, // BGRBGR…BGR, B at the lowest address FMT_RGBA8888, // RGBARGBA…RGBA, R at the lowest address FMT_BGRA8888, // BGRABGRA…BGRA, B at the lowest address FMT_RGB565, FMT_BGR565, FMT_YUV422SP, // YYY…UVUVUV…UVUV FMT_YUV422P, // YYY…UUU…VVV FMT_YVU420SP, // YYY…VUVUVU…VUVU, NV21 FMT_YUV420SP, // YYY…UVUVUV…UVUV, NV12 FMT_YVU420P, // YYY…VVV…UUU FMT_YUV420P, // YYY…UUU…VVV FMT_GRAYSCALE, FMT_BGGR6, // 6-bit Bayer format with a BGGR pattern. FMT_GBRG6, // 6-bit Bayer format with a GBRG pattern. FMT_GRBG6, // 6-bit Bayer format with a GRBG pattern. FMT_RGGB6, // 6-bit Bayer format with a RGGB pattern. FMT_BGGR8, // 8-bit Bayer format with a BGGR pattern. FMT_GBRG8, // 8-bit Bayer format with a GBRG pattern. FMT_GRBG8, // 8-bit Bayer format with a GRBG pattern. FMT_RGGB8, // 8-bit Bayer format with a RGGB pattern. FMT_BGGR10, // 10-bit Bayer format with a BGGR pattern. FMT_GBRG10, // 10-bit Bayer format with a GBRG pattern. FMT_GRBG10, // 10-bit Bayer format with a GRBG pattern. FMT_RGGB10, // 10-bit Bayer format with a RGGB pattern. FMT_BGGR12, // 12-bit Bayer format with a BGGR pattern. FMT_GBRG12, // 12-bit Bayer format with a GBRG pattern. FMT_GRBG12, // 12-bit Bayer format with a GRBG pattern. FMT_RGGB12, // 12-bit Bayer format with a RGGB pattern. FMT_UNCOMPRESSED_MAX,
最新发布
03-26
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值