题目描述
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.
Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
输入
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
输出
For each A in the input, output a line containing only its lowest bit.
示例输入
26 88 0
示例输出
2 8
#include<stdio.h>
#include<string.h>
#include<math.h>
#define N 1010
int main()
{
int n,i;
while(~scanf("%d",&n))
{
if(n==0)
{
break;
}
else
{
int t=0;
while(n%2==0)
{
t++;
n=n/2;
}
printf("%d\n",(int)pow(2,t));//表示2的n次方
}
}
return 0;
}