网络通信
RUN IT
这个作者很懒,什么都没留下…
展开
专栏收录文章
- 默认排序
- 最新发布
- 最早发布
- 最多阅读
- 最少阅读
-
websocket的介绍
websocket的介绍WebSocket是一种在单个TCP连接上进行全双工通讯的协议。WebSocket通信协议于2011年被IETF定为标准RFC 6455,并由RFC7936补充规范。WebSocket API也被W3C定为标准。WebSocket使得客户端和服务器之间的数据交换变得更加简单,允许服务端主动向客户端推送数据。在WebSocket API中,浏览器和服务器只需要完成一次握手...原创 2020-04-01 19:09:33 · 353 阅读 · 0 评论 -
RUN__IT # mysql远程连接问题
mysql远程连接问题服务器端口开放1.mysql默认端口是 3306,所以要开放此端口编辑 mysql 的配置文件 mysqld.cnf1.执行 sudo vi /etc/mysql/mysql.conf.d/mysqld.cnf2.把 bind-address = 127.0.0.1 注释掉1.在装有MySQL的机器上登录MySQL mysql -u root -p密码...原创 2019-11-28 15:30:52 · 190 阅读 · 0 评论 -
RUN__IT # TCP创建服务器与客户端
创建客户端与服务器,实现客户端能从服务器下载与上传文件tcp创建套接字(socket)知识总结:tcp客户端创建1.创建套接字tcp_client_socket = socket.socket(socket.AF_INET,socket.SOCKJ_STREAM)2.链接服务器tcp_client_socket.connect(("server_ip",server_port))3....原创 2019-04-08 21:49:32 · 738 阅读 · 0 评论 -
RUN__IT # 使用http协议创建并发服务器多种版本
不同版本使用多进程完成http服务器使用多线程实现http服务器使用协程gevent完成http服务器单进程-单线程-非阻塞http服务器使用epoll实现http服务器程序中所用到的文件html是一个网页页面文件,不再上传。使用多进程完成http服务器import socketimport reimport multiprocessingdef sever_client(new_...原创 2019-04-18 20:20:59 · 499 阅读 · 0 评论 -
RUN__IT # HTTP协议--三次握手四次挥手
HTTP,HyperText Transfer Protocol。超文本传输协议,是互联网上应用最为广泛的一种网络协议。基于TCP的协议,HTTP是一个客户端和服务器端请求和应答的标准。udp是User Datagram Protocol的简称,是用户数据报协议。无连接的传输层协议。tcp是Transmission Control Protocol,缩写为 TCP。是传输控制协议。是一种面...原创 2019-04-18 21:05:50 · 618 阅读 · 0 评论 -
RUN__IT # HTTP状态码解析
HTTP状态码(HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的,并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。一、1xx(临时响应)表示临时响应并需要请求者继续执行操作的状态码。100(继续) 请求者应当继续提出请求。服务器返回此代码表示已收到请求的第一部分,...原创 2019-07-17 21:09:11 · 471 阅读 · 0 评论
分享