运维
RUN IT
这个作者很懒,什么都没留下…
展开
专栏收录文章
- 默认排序
- 最新发布
- 最早发布
- 最多阅读
- 最少阅读
-
RUN__IT # Python的日志----logging的使用
方法1 最普通的日志 import logging import time # 定义logger logger = logging.getLogger('mylogger') # 日志等级 logger.setLevel(logging.INFO) f_handler = logging.FileHandler('./log/log.log') f_handler.setFormatter(logging.Formatter("%(asctime)s - %(levelname)s - %(filen原创 2020-08-05 23:41:49 · 223 阅读 · 0 评论 -
RUN__IT # python发送邮件工具包
发送邮件 1.可用直接用拿来使用,一个工具类修改邮箱密码后,在需要发邮件的地方直接调用 import smtplib from email.mime.text import MIMEText from email.header import Header class SendEmailTask(object): """发送邮件""" def __init__(self): self.mail_host = "smtp.qq.com" self.mail_u原创 2020-08-01 15:26:38 · 321 阅读 · 0 评论 -
RUN__IT @ 一台新的服务器的环境安装
1.创建用户 1.useradd -m -g 组 新建用户名 2.passwd 用户名 3.usermod -s /bin/bash 用户名 4.给用户添加sudo权限 chmod +w /etc/sudoers vi /etc/sudoers 添加权限,类似root用户那样格式 用户名 ALL=(ALL:ALL) ALL 2.更新源 sudo apt-get update 3...原创 2019-11-28 15:35:42 · 343 阅读 · 0 评论 -
RUN__IT # mysql远程连接问题
mysql远程连接问题 服务器端口开放 1.mysql默认端口是 3306,所以要开放此端口 编辑 mysql 的配置文件 mysqld.cnf 1.执行 sudo vi /etc/mysql/mysql.conf.d/mysqld.cnf 2.把 bind-address = 127.0.0.1 注释掉 1.在装有MySQL的机器上登录MySQL mysql -u root -p密码...原创 2019-11-28 15:30:52 · 190 阅读 · 0 评论 -
RUN__IT # linux命令 2>&1与 系统垃圾桶
2>&1 与 /dev/null2>&1linux系统垃圾桶 2>&1 符号详解: 1 表示正确输出信息 2 表示错误输出信息 2>&1 表示所有输出信息 标准正确输出示例 cat nihao.txt 1> zhengque 标准错误输出示例 dsfadsfadsfa 2>> errfile 看完这个命令和示例,有的人就想说...原创 2019-03-24 23:59:10 · 1048 阅读 · 0 评论 -
RUN__IT # python中pip的安装与使用
pip检查是否安装了pippip的安装与升级pip的使用 检查是否安装了pip 大多数较新的python版本都自带pip,因此首先检查是否安装了pip。在python3中,pip有时被称为pip3. 1、在linux和osx系统中检查是否安装了pip 打开终端窗口,执行命令:$ pip --version 看到正确的信息,pip的版本号,则安装有pip。 如果看到错误消息,请尝试将pip替换为...原创 2019-03-30 14:23:14 · 1230 阅读 · 0 评论 -
RUN__IT # mysql数据库的windows安装方法
Windows安装MySQL5.7 1.解压压缩包到本地(这个路径可以是你电脑上的任意路径,但不要有中文或其他特殊字符) 目录内部如下: 2.在你解压过的目录C:\mysql-5.7.22-winx64下面新建my.ini文件,把下面的代码直接粘贴到my.ini,注意路径要写你电脑上的路径 [mysqld] port = 3306 basedir=C:/mysql-5.7.22-winx64 ...原创 2019-04-20 11:14:05 · 660 阅读 · 0 评论 -
RUN__IT # 快速掌握shell编程
shell的定义 在计算机科学中,Shell就是一个命令解释器。 shell是位于操作系统和应用程序之间,是他们二者最主要的接口,shell负责把应用程序的输入命令信息解释给操作系统,将操作系统指令处理后的结果解释给应用程序。 查看系统shell信息 查看当前系统的shell类型 echo $SHELL 查看当前系统环境支持的shell [root@linux-node1 ~]# cat /et...原创 2019-04-20 12:10:36 · 772 阅读 · 0 评论 -
RUN__IT # shell编程练习(自动创建用户)
#!/bin/bash :<<! 1.自动生成新用户,并且为新用户设置密码。如果用户已存在则不创建。 2.参数可以有1个或2 个: 1个参数则用户和组名是同一个. 2个参数的话,第一个为用户名,第二个为组名 3.脚本运行方式:bash useradd.sh zhangsan dev 或者 bash useradd.sh lisi ! user_name=$1 grou...原创 2019-04-20 13:49:02 · 626 阅读 · 0 评论 -
RUN__IT # 从windows不能复制文件到ubuntu?
复制过来的东西会在此路径下: /var/run/vmblock-fuse/blockdir/sZiUaA/ 若果此路径下文件过多多大,都会有影响,可以 rm 这个路径下的文件。然后复制下试试。 如果不行,可以试试如下命令: 第一步: sudo apt-get autoremove open-vm-tools 第二步:sudo apt-get install open-vm-tools-de...原创 2019-06-07 00:34:09 · 2032 阅读 · 0 评论 -
RUN__IT # 除了负载均衡,Nginx还可以做很多
Nginx应该是现在最火的web和反向代理服务器,没有之一。她是一款诞生于俄罗斯的高性能web服务器,尤其在高并发情况下,相较Apache,有优异的表现。那除了负载均衡,她还有什么其他的用途呢,下面我们来看下。 一、静态代理 Nginx擅长处理静态文件,是非常好的图片、文件服务器。把所有的静态资源的放到nginx上,可以使应用动静分离,性能更好。 二、负载均衡 Nginx通过反向代理可以实现服务...原创 2019-06-25 14:49:35 · 346 阅读 · 0 评论 -
RUN__IT #虚拟环境的创建和使用
创建虚拟环境与使用 1.sudo pip3 install virtualenv 2.sudo pip3 install virtualenvwrapper 3.ll看一下有没有这个 .virtualenvs 没有就创建 mkdir $HOME/.virtualenvs 4.打开~/.bashrc 文件,并添加如下 sudo vim ~/.bashrc 添加一下配置在最后 export WORK...原创 2019-06-29 17:36:22 · 350 阅读 · 0 评论 -
RUN__IT # HTTP状态码解析
HTTP状态码(HTTP Status Code)是用以表示网页服务器HTTP响应状态的3位数字代码。它由 RFC 2616 规范定义的,并得到RFC 2518、RFC 2817、RFC 2295、RFC 2774、RFC 4918等规范扩展。 一、1xx(临时响应) 表示临时响应并需要请求者继续执行操作的状态码。 100(继续) 请求者应当继续提出请求。服务器返回此代码表示已收到请求的第一部分,...原创 2019-07-17 21:09:11 · 471 阅读 · 0 评论 -
RUN__IT # 优快云编辑器markdown字体、颜色与字号的设置
首先我们需要明白markdown里面的标记语言可以使用标签对来实现对文本文字颜色大小信息的控制。下面给出几个实例: <font face="黑体">黑体字示例</font> <font face="微软雅黑">微软雅黑示例</font> <font face="STCAIYUN">华文彩云示例</font> <font ...原创 2019-07-17 21:17:41 · 292 阅读 · 0 评论 -
RUN__IT # pycharm设置
pycharm常用快捷键 1、编辑(Editing) Ctrl + Space 基本的代码完成(类、方法、属性) Ctrl + Alt + Space 快速导入任意类 Ctrl + Shift + Enter 语句完成 Ctrl + P 参数信息(在方法中调用参数) Ctrl + Q 快速查看文档 F1 外部文档 Shift + F1 外部文档,进入web文档主...原创 2019-07-31 13:41:23 · 709 阅读 · 0 评论 -
RUN__IT # 定时任务操作
# 1.crontab安装 服务器自带 mac brew install cronolog unbutu apt-get install cron winows .exe下载 # 2.编辑任务 crontab -e 任务格式 分 时 日 月 星期 命令 m h d m week command 30 * * * * l...原创 2019-08-28 10:06:41 · 277 阅读 · 0 评论 -
RUN__IT # 服务器上安装selenum及其出现的问题
一:首先在服务器上安装chrome和其对应的chromedriver。这个非常重要,一定要下载和安装其一一对应的版本。 安装chrome sudo apt-get install libxss1 libappindicator1 libindicator7 wget https://dl.google.com/linux/direct/google-chrome-stable_current_am...原创 2019-09-01 21:44:04 · 234 阅读 · 0 评论 -
RUN__IT # Ubuntu下使用crontab创建定时任务
Ubuntu下使用crontab创建定时任务 安装:apt-get install cron 启动:service cron start 重启:service cron restart 停止:service cron stop 检查状态:service cron status 查询cron可用的命令:service cron 检查Cronta工具是否安装:crontab -l 如果cron工作正...原创 2019-11-07 15:51:29 · 198 阅读 · 0 评论
分享