ACM Curling 2.0(挑战程序设计竞赛)

在MM-21星球上,一种类似冰壶的运动正在流行,但规则有所不同。玩家需要将石头从起点推到终点,途中可能需要利用阻挡物进行转向,最少步数为胜利。游戏结束条件包括石头超过10次移动未到达终点或成功抵达终点。输入包含关卡地图,输出是最小移动次数,若无法到达则输出-1。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Curling 2.0

Time Limit: 1000ms
Memory Limit: 65536KB
This problem will be judged on  PKU. Original ID:  3009
64-bit integer IO format:  %lld      Java class name:  Main
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

    Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


    Fig. 1: Example of board (S: start, G: goal)

    The movement of the stone obeys the following rules:

    • At the beginning, the stone stands still at the start square.
    • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
    • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
    • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
      • The stone hits a block (Fig. 2(b), (c)).
        • The stone stops at the square next to the block it hit.
        • The block disappears.
      • The stone gets out of the board.
        • The game ends in failure.
      • The stone reaches the goal square.
        • The stone stops there and the game ends in success.
    • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


    Fig. 2: Stone movements

    Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

    With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


    Fig. 3: The solution for Fig. D-1 and the final board configuration

    Input

    The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

    Each dataset is formatted as follows.

    the width(=w) and the height(=h) of the board 
    First row of the board 
    ... 
    h-th row of the board

    The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

    Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

    0vacant square
    1block
    2start position
    3goal position

    The dataset for Fig. D-1 is as follows:

    6 6 
    1 0 0 2 1 0 
    1 1 0 0 0 0 
    0 0 0 0 0 3 
    0 0 0 0 0 0 
    1 0 0 0 0 1 
    0 1 1 1 1 1

    Output

    For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

    Sample Input

    2 1
    3 2
    6 6
    1 0 0 2 1 0
    1 1 0 0 0 0
    0 0 0 0 0 3
    0 0 0 0 0 0
    1 0 0 0 0 1
    0 1 1 1 1 1
    6 1
    1 1 2 1 1 3
    6 1
    1 0 2 1 1 3
    12 1
    2 0 1 1 1 1 1 1 1 1 1 3
    13 1
    2 0 1 1 1 1 1 1 1 1 1 1 3
    0 0

    Sample Output

    1
    4
    -1
    4
    10
    -1

    Source

    题目大意:一个冰壶游戏.开始时冰壶在S处,你可以向上下左右四个方向推冰壶,前提是那个方向没有紧挨这一个物块.
    冰壶碰到物块会停在那个物块前,并且碰到的那个物块会小时.
    注意冰壶到G时会立即停下
    冰壶掉出区域算失败
    求冰壶从S到G最少要推几次
    如果不能在10次能完成输出-1,否则输出最小要推的次数

    解题思路:
    深度优先搜索
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    
    using namespace std;
    
    #define MAX_W 20
    #define INF 99
    
    int dx[]={1,-1,0,0};
    int dy[]={0,0,1,-1};
    
    int w,h;
    int sx,sy;
    int ex,ey;
    int map[MAX_W][MAX_W];
    int mintimes;
    
    void dfs(int x,int y,int cur)
    {
    	if(cur==10 && map[y][x]!=3) return;
    	else if(map[y][x]==3)
    	{
    		mintimes=min(mintimes,cur);
    		return;
    	}
    
    	for(int i=0;i<4;i++)
    	{
    		int nx=x+dx[i],ny=y+dy[i];
    
    		if(nx>=0 && nx<w && ny>=0 && ny<h)
    		{
    			if(map[ny][nx]==1)
    				continue;
    
    			while(nx>=0 && nx<w && ny>=0 && ny<h && map[ny][nx]!=1 && map[ny][nx]!=3)
    			{
    				nx+=dx[i];ny+=dy[i];
    			}
    
    			if(nx<0 || nx>=w || ny<0 || ny>=h) continue;
    
    			int co=map[ny][nx];
    			int cx=nx,cy=ny;
    			if(map[ny][nx]==1)
    			{
    				map[ny][nx]=0;
    				ny-=dy[i];nx-=dx[i];
    			}
    			dfs(nx,ny,cur+1);
    			map[cy][cx]=co;
    		}
    	}
    }
    
    int main()
    {
    	scanf("%d%d",&w,&h);
    
    	while(w!=0 || h!=0)
    	{
    		for(int i=0;i<h;i++)
    		for(int j=0;j<w;j++)
    		{
    			scanf("%d",&map[i][j]);
    			if(map[i][j]==2)
    			{
    				sx=j;sy=i;
    			}
    			else if(map[i][j]==3)
    			{
    				ex=j;ey=i;
    			}
    		}
    
    		mintimes=INF;
    		dfs(sx,sy,0);
    		if(mintimes==INF)
    			printf("-1\n");
    		else
    			printf("%d\n",mintimes);
    
    		scanf("%d%d",&w,&h);
    	}
    
    	return 0;
    }
    



    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值