PTA--1030 Travel Plan(最短路+记录路径)

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

题意:给定n个点,m条边,起点x和终点y,每条边有四个参数,分别表示两端和距离和途径花费,问你x到y最短路径是哪条,如果不止一条,那么就选择花费少的,要求你输出路径和最短路径和最短花费。

解析:最短路跑一边即可,记录一个路径path,跑最短路时记录下这个点的前置点是谁,最后从终点返回起点,最后反转一下就是路径。

#include <bits/stdc++.h>
using namespace std;
const int N=505;
struct node
{
    int a,b,c;
};
vector<node> v[N];
vector<int> path;
int dist[N],cost[N],pre[N],x,y;
//分别记录到某点的距离和花费
bool vis[N];
void spfa()
{
    queue<int> q;
    q.push(x);
    memset(dist,0x3f,sizeof dist);//初始化
    dist[x]=0;
    while(q.size())
    {
        int u=q.front();
        q.pop();
        vis[u]=false;
        for(int i=0;i<v[u].size();i++)
        {
            int j=v[u][i].a;//邻点
            int s=v[u][i].b;//距离
            int w=v[u][i].c;//花费
            if(dist[j]>dist[u]+s)//更新最短路
            {
                dist[j]=dist[u]+s;
                cost[j]=cost[u]+w;
                pre[j]=u;//记录前置点是u
                if(!vis[j])
                {
                    q.push(j);
                    vis[j]=true;
                }
            }else if(dist[j]==dist[u]+s)//如果相同,取花费小的
            {
                if(cost[u]+w<cost[j])
                {
                    cost[j]=cost[u]+w;
                    pre[j]=u;
                    if(!vis[j])
                    {
                        q.push(j);
                        vis[j]=true;
                    }
                }
            }
        }
    }
}
void solve()
{
    int n,m;
    scanf("%d%d%d%d",&n,&m,&x,&y);
    for(int i=1;i<=m;i++)
    {
        int a,b,c,d;
        scanf("%d%d%d%d",&a,&b,&c,&d);
        v[a].push_back({b,c,d});
        v[b].push_back({a,c,d});
    }
    spfa();
    int pos=y;//从终点往回走
    while(pos!=x)
    {
        path.push_back(pos);
        pos=pre[pos];
    }
    path.push_back(x);
    reverse(path.begin(), path.end());//反转路径
    for(int i=0;i<path.size();i++) printf("%d ",path[i]);
    printf("%d %d\n",dist[y],cost[y]);
}
int main()
{
    int t=1;
    while(t--) solve();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值