1085 Perfect Sequence (25 point(s))
Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤105) is the number of integers in the sequence, and p (≤109) is the parameter. In the second line there are N positive integers, each is no greater than 109 .
Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8
题目大意
给定一个数列和p,要求挑出一个子列,同时该子列的最大值M和最小值m要满足M <= m*p,要求输出满足条件的最长子列的长度
解题思路
先将该数组排序,并查找该位置数字*p所在位置,找到两个位置差的最大值即可。此处即可用二分查找也可使用STL自带的upper_bound函数
代码
#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <algorithm>
using namespace std;
long long arr[100005] = { 0 };
int main()
{
long long N, p;
int ret = scanf("%lld%lld", &N, &p);//输入必须使用%lld
int i, MAX_cnt = -1;
for (i = 0; i < N; ++i) {
ret = scanf("%lld", &arr[i]);
}
sort(arr, arr + N);
for (i = 0; i < N; ++i) {
long long bound = arr[i] * p;
//寻找其所在位置
int left = i, right = N - 1;
while (left <= right) {//二分查找,此处也可使用upper_bound函数,代码会更加简洁
int mid = (left + right) / 2;
if (arr[mid] > bound) {
right = mid - 1;
}
else {
left = mid + 1;
}
}
MAX_cnt = max(MAX_cnt, left - i);//最长序列
}
printf("%d", MAX_cnt);
return 0;
}