题目 1096: Minesweeper<扫雷>

时间限制: 1Sec 内存限制: 64MB 提交: 3911 解决: 1644

题目描述

Minesweeper Have you ever played Minesweeper? This cute little game comes with a certain operating system whose name we can’t remember. The goal of the game is to find where all the mines are located within a M x N field. The game shows a number in a square which tells you how many mines there are adjacent to that square. Each square has at most eight adjacent squares. The 4 x 4 field on the left contains two mines, each represented by a ``*’’ character. If we represent the same field by the hint numbers described above, we end up with the field on the right: … … .… … 100 2210 110 1110

输入

The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m ( 0 < n, m$ \le$100) which stand for the number of lines and columns of the field, respectively. Each of the next n lines contains exactly m characters, representing the field. Safe squares are denoted by ‘.’ and mine squares by ‘*’, both without the quotes. The first field line where n = m = 0 represents the end of input and should not be processed.

输出

For each field, print the message Field #x: on a line alone, where x stands for the number of the field starting from 1. The next n lines should contain the field with the ``.’’ characters replaced by the number of mines adjacent to that square. There must be an empty line between field outputs.

样例输入

4 4


.


3 5
**…

.*…
0 0

样例输出

Field #1:
100
2210
1
10
1110

Field #2:
**100
33200
1*100

程序实现

#include<stdio.h>
char field[200][200];//地图 
int calculate[200][200];//探测数组 
int main()
{
	int n,m;//行数和列数
	int time=0;//记录地雷在附近出现的个数 
	while(scanf("%d %d",&n,&m)&&n!=0&&m!=0)
	{
		time++;
		for(int i=0;i<n;i++)
		{
			scanf("%s",field[i]);//注意二维字符数组的输入方式,不可用%c按字符读入 
			for(int j=0;j<m;j++)
			{
				calculate[i][j]=0;
			}
		}
		printf("Field #%d:\n",time);
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<m;j++)
			{
				if(field[i][j]=='*')
				{
					//calculate[i][j]=-1;
					printf("*");//地雷 
				}
				else
				{	//探测该方块的八个方位,出现地雷则该位置探测数加一 
					if(i-1>=0&&j-1>=0&&field[i-1][j-1]=='*')
						calculate[i][j]++;
					if(i-1>=0&&field[i-1][j]=='*')
						calculate[i][j]++;
					if(i-1>=0&&j+1<m&&field[i-1][j+1]=='*')
						calculate[i][j]++;
					if(j-1>=0&&field[i][j-1]=='*')
						calculate[i][j]++;
					if(j+1<m&&field[i][j+1]=='*')
						calculate[i][j]++;
					if(i+1<n&&j-1>=0&&field[i+1][j-1]=='*')
						calculate[i][j]++;
					if(i+1<n&&field[i+1][j]=='*')
						calculate[i][j]++;
					if(i+1<n&&j+1<n&&field[i+1][j+1]=='*')
						calculate[i][j]++;
					printf("%d",calculate[i][j]);//打印探测数 
				}
			}
			printf("\n");
		}
		printf("\n");
	}
	return 0;
}

实现结果

在这里插入图片描述

谢谢观看

### PTA平台扫雷题解决方案 对于PTA平台上编号为6-22的扫雷题目,解决该类问题通常涉及创建一个二维数组来表示游戏板,并通过遍历此数组计算每个位置周围的地雷数量。下面给出一种可能实现方法。 #### 创建并初始化游戏板 首先定义宏MINESWEEPER用于标记地雷字符以及空白区域字符,在main函数内声明两个二维字符数组board和mask分别存储实际地图与玩家视角下的状态图。利用双重循环随机布置一定量的地雷于board中[^1]。 ```c #define MINESWEEPER '*' char board[ROW][COL], mask[ROW][COL]; srand((unsigned)time(NULL)); for (int i = 0; i < MINECOUNT;) { int row = rand() % ROW, col = rand() % COL; if (board[row][col] != MINESWEEPER){ board[row][col] = MINESWEEPER; ++i; } } ``` #### 计算非地雷格子周围地雷数目 接着设计辅助函数countMines负责统计指定坐标四周八个方向上存在的地雷总数,并更新至对应位置处;注意边界条件处理以免越界访问内存地址引发错误[^2]。 ```c void countMines(int r, int c) { static const int dr[] = {-1,-1,-1, 0, 0, 1, 1, 1}; static const int dc[] = {-1, 0, 1,-1, 1,-1, 0, 1}; char num = '0'; for (size_t d = 0; d < sizeof(dr)/sizeof(*dr);++d) { int nr=r+dr[d],nc=c+dc[d]; if ((nr>=0 && nr<ROW)&&(nc>=0&&nc<COL)){ if(board[nr][nc]==MINESWEEPER) ++num; } } if(num>'0') board[r][c]=num; } ``` #### 显示当前局面给用户查看 最后提供printBoard接口用来打印出带有边框装饰的游戏界面供用户体验交互过程中的变化情况[^3]。 ```c void printBoard(){ printf("+-"); for(size_t j=0;j<COL;++j) putchar('-'); puts("+"); for (size_t i = 0;i<ROW ;++i ) { printf("| "); for (size_t j = 0;j<COL ;++j ) putchar(mask[i][j]); puts(" |"); } printf("+-"); for(size_t k=0;k<COL ;++k ) putchar('-'); puts("+"); } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值