PAT甲级----1038 Recover the Smallest Number (30分)

1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

这题解法比较独特,比较的时候只需要比较a+b和b+a即可,如果a+b拼接出的字符串大于b+a拼接出的字符串,那么就将b+a放前面,否则将a+b放前面,最后去除前导零即可
#include<bits/stdc++.h>

using namespace std;

int n;
string ss = "";
vector<string>v;
map<string,int>vis,ans;

bool cmp(string a , string b)
{
	return a + b < b + a;
}

int main()
{
	cin >> n;
	for(int i = 0 ; i < n ; i++)
	{
		string s;
		cin >> s;
		v.push_back(s);
	}
	sort(v.begin(),v.end(),cmp);
	string ans = "";
	for(int i = 0 ; i < v.size() ; i++)
		ans += v[i];
	int i = 0;
	while(ans[i] == '0' && i < ans.size())
		i++;
	string ans2 = "";
	for(int j = i ; j < ans.size() ; j++)
		ans2 += ans[j];
	if(!ans2.size())
		cout << "0";
	else
		cout << ans2;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柠檬ya

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值