PAT甲级——(1032) Sharing

本文介绍了一种使用链表存储英文单词的方法,并详细解释了如何通过共享相同后缀来节省空间。针对两个链表,文章提出了一种算法来找到它们共用结点的起始位置,适用于单词存储场景。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).
Input Specification:
Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10
​5
​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:
Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.
Output Specification:
For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.
Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:
67890

Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

题意:给出两条链表的首地址以及若干结点的地址、数据、下一个结点的地址,求两条链表的首个共用结点的地址。如果两条链表没有共用结点,则输出-1.

#include<stdio.h>
#include<cstring>

const int maxn = 100010;
struct NODE {
	char data;//数据
	int next;//指针域
	bool flag;
}node[maxn];

int main() {
	for (int i = 0; i < maxn; i++) {
		node[i].flag = false;
	}

	int s1, s2, n;//s1与s2分别代表两条链表的首地址
	scanf("%d%d%d", &s1, &s2, &n);
	int address, next;
	char data;
	for (int i = 0; i < n; i++) {
		scanf("%d %c %d", &address, &data, &next);
		node[address].data = data;
		node[address].next = next;
	}
	int p;
	for (p = s1; p != -1; p = node[p].next) {
		node[p].flag = true;
	}
	for (p = s2; p != -1; p = node[p].next) {
		if (node[p].flag == true)break;
	}	
	if (p != -1) {
		printf("%05d\n", p);
	}
	else {
		printf("-1\n");
	}
	return 0;
}

思路:
1.由于地址的范围很小,因此可以直接用静态链表。在结点的结构体中再定义一个int型变量flag,表示结点是否在第一条链表中出现,是则为1,不是为-1。
2.从第一条链表的首地址出发遍历第一条链表,将经过的所有结点的flag值赋为-1。
3.枚举第二条链表,当出现第一个flag值为1的结点,说明是第一条链表中出现过的结果,即为两条链表的第一个共用结点。如果第二条链表枚举完仍然没有发现共用结点,则输出-1。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值