PAT 1042 Shuffling Machine

博客围绕模拟扑克牌自动洗牌机展开,介绍了洗牌机按给定随机顺序对54张牌洗牌并重复指定次数的原理,给出了牌的初始顺序,还说明了输入输出规格,涉及算法和数据结构知识。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

#include <iostream>
#include <vector>
#include <string>
using namespace std;
string str[] = {" ", "S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
                "H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
                "C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
                "D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
                "J1","J2",};

/*
    用两个vector重复进行 存放 扑克牌需要达到的位置 
    比如 现在cards1 作为初始化的牌序 给定了一个order 那么就将cards1中每张牌放进它移动后的位置 而这张牌 需要放进cards2里面
    而cards2中的牌移动后要放进cards1里面 就这样反反复复直至 重复次数为0
*/
int main(){
    int k; //重复次数 
    
    int order;//每个牌对应的序列号 
    
    vector<string> cards1(str, str + 55); //初始化的牌序 
    vector<string> cards2(55); 
   
    cin >> k;
    
    int ans[55] = {0}; //存放order
    int i = 1;
    
    while(cin >> order){ //将order存放至数组中 
        ans[i++] = order;
    }
    
    bool flag = true; //做标记
	 
    while(k--){
        for(int i=1; i<55; i++){
            if(flag){
                int tmp = ans[i];
                cards2[tmp] = cards1[i];
            }
            else{
                int tmp = ans[i];
                cards1[tmp] = cards2[i];
            }
        }
        flag = !flag; 
    }
    
    if(!flag){
    	for(int i=1; i<54; i++){
    		cout << cards2[i] << " ";
		}
		cout << cards2[54] << endl;
	} 
	else{
		for(int i=1; i<54; i++){
			cout << cards1[i] << " ";
		}
		cout << cards1[54] << endl;
	}
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值