问题 B: Student List for Course (25)

input

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

output

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

样例输入 Copy

10 5
ZOE1 2 4 5
ANN0 3 5 2 1
BOB5 5 3 4 2 1 5
JOE4 1 2
JAY9 4 1 2 5 4
FRA8 3 4 2 5
DON2 2 4 5
AMY7 1 5
KAT3 3 5 4 2
LOR6 4 2 4 1 5

样例输出

1 4
ANN0
BOB5
JAY9
LOR6
2 7
ANN0
BOB5
FRA8
JAY9
JOE4
KAT3
LOR6
3 1
BOB5
4 7
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1
5 9
AMY7
ANN0
BOB5
DON2
FRA8
JAY9
KAT3
LOR6
ZOE1

代码

//!<vector>容器经典问题 
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cstring>
using namespace std;
const int maxnum=40009;
char name[maxnum][5]={0};//
//用来sort函数的判断 
//用整数来代替一个字符串,用到二维数组! 
bool cmp1(int a,int b)
{
	return (strcmp(name[a],name[b])<0);
}
//构建一个容器 
vector<int> stu[maxnum];
vector<int>::iterator it;
//主函数 
int main()
{
	int N,K,C;
	scanf("%d %d",&N,&K);
	//输入进去容器 
	for(int i=0;i<N;i++)
	{
		scanf("%s %d",name[i],&C);
		while(C--)
		{
			int a;
			scanf("%d",&a);
			stu[a].push_back(i);
		}
	}
	//进行输出 
	for(int j=1;j<=K;j++)
	{
		printf("%d %d\n",j,stu[j].size());
		//排序 
		sort(stu[j].begin(),stu[j].end(),cmp1);
		//应为容器里装的是int,但是每一个整数i对应一个name[i],也就是可以用整数来替代名字。 
		for(it=stu[j].begin();it!=stu[j].end();it++){
			printf("%s\n",name[*it]);
		}
	} 
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值