PAT 甲级1001 A+B Format (20 分)

1001 A+B Format 20 分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106​≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

题目大意:

  给定两个整数,求他们的和,按照每三位输出一个逗号的格式输出和,当和小于三位数时则不用输出逗号。

 

思路:

  1. 求和且在整数范围内,用int 变量 存储原始的两个整数。
  2. 利用to_string() 函数与string变量存储结果,方便控制逗号的输出。 
  3. 注意输出‘,’ 的控制,注意到string 变量中的低位存储结果的高位。 逗号的控制如:

参考代码:

#include<iostream>
using namespace std;
int main (){
	int f1, f2;
	cin >> f1 >> f2;
	string ans = to_string(f1 + f2);
	for(int i = 0; i < ans.length(); i++){
		printf("%c", ans[i]);
		if(ans[i] == '-')	continue;
		if((ans.length() - 1 - i) % 3 == 0 && i != ans.length() - 1)	
               printf(",");
	}
	return 0;
}

 

代码参考了https://blog.youkuaiyun.com/liuchuo/article/details/51985923  

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值