1001 A+B Format (20 分)
Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
题目大意:
给定两个整数,求他们的和,按照每三位输出一个逗号的格式输出和,当和小于三位数时则不用输出逗号。
思路:
- 求和且在整数范围内,用int 变量 存储原始的两个整数。
- 利用to_string() 函数与string变量存储结果,方便控制逗号的输出。
- 注意输出‘,’ 的控制,注意到string 变量中的低位存储结果的高位。 逗号的控制如:
参考代码:
#include<iostream>
using namespace std;
int main (){
int f1, f2;
cin >> f1 >> f2;
string ans = to_string(f1 + f2);
for(int i = 0; i < ans.length(); i++){
printf("%c", ans[i]);
if(ans[i] == '-') continue;
if((ans.length() - 1 - i) % 3 == 0 && i != ans.length() - 1)
printf(",");
}
return 0;
}
代码参考了https://blog.youkuaiyun.com/liuchuo/article/details/51985923