Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
大致思路是:
先读入每个小考场,对每个小考场进行内部排序,每个学生获取考场号及考场内排名,再对所有考生进行排序,一边计算最终排名,一边输出。
几个注意点:
【1】结构体的设计;
【2】排名的计算,eg:1,2,2,4,这个4就是当前人数个数;
【3】sort函数,cmp函数,strcmp函数。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Student{
char id[15];
int score;
int loc_num;
int loc_rank;
}stu[30010];
bool cmp(Student a, Student b){ //默认先排分数,分数相同,考号小的优先?
if(a.score!=b.score) return a.score>b.score;
else return strcmp(a.id,b.id)<0;
}
int main(){
int n;
scanf("%d",&n);
int num=0; //记录总人数
for(int i=1;i<=n;i++){ //考场循环,第i考场
int k;
scanf("%d",&k);
for(int j=0;j<k;j++){ //读入单个考场
scanf("%s %d",stu[num].id,&stu[num].score);
stu[num].loc_num=i;
num++;
}
sort(stu+num-k,stu+num,cmp); //排序
stu[num-k].loc_rank=1;
for(int m=num-k+1;m<num;m++){
if(stu[m].score==stu[m-1].score) stu[m].loc_rank=stu[m-1].loc_rank;
else stu[m].loc_rank=m-(num-k)+1; //第几名
}
}
printf("%d\n",num);
sort(stu,stu+num,cmp);
int rank=1;
for(int i=0;i<num;i++){
if(i==0){
printf("%s %d %d %d\n",stu[i].id,rank,stu[i].loc_num,stu[i].loc_rank);
}else{
if(stu[i].score!=stu[i-1].score){
rank=i+1;
}
printf("%s %d %d %d\n",stu[i].id,rank,stu[i].loc_num,stu[i].loc_rank);
}
}
return 0;
}