1099 Build A Binary Search Tree (30分)

 

1099 Build A Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42
#include <iostream>
#include <algorithm>
#include<vector>
#include<map>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<set>
#include<unordered_map>
#include<queue>
#include<climits>
#include<stack>
using namespace std;
const int maxn= 10000+10;

struct Node{
	int data,l,r,index,lever;
		
}a[maxn];

int in[maxn],b[maxn];

int n,k=0;

bool cmp(Node x,Node y){
	if(x.lever!=y.lever) return x.lever<y.lever;
	return x.index<y.index;
	
}

int cnt=0;
void inorder(int root ,int index,int lever){
	
		if(a[root].l!=-1) inorder(a[root].l,index*2+1,lever+1);
		a[root]={b[cnt++],a[root].l,a[root].r,index,lever};
		if(a[root].r!=-1) inorder(a[root].r,index*2+2,lever+1);
	
}

int main(){
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>a[i].l>>a[i].r;		
	}
	for(int i=0;i<n;i++){
		cin>>b[i];
	}
	sort(b,b+n);
	inorder(0,0,0);
	sort(a,a+n,cmp); 
	for(int i=0;i<n;i++) {
		if(i!=0) cout<<" ";
		cout<<a[i].data;
	} 
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值