PAT 甲级 1028 List Sorting (25分)

本文介绍了一种算法,用于模仿Excel的记录排序功能。该算法接收学生记录和指定的排序列,能够按照ID、姓名或成绩进行升序排序,并在姓名或成绩相同时依据ID排序。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目

1028 List Sorting (25分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意

给出N条记录和筛选的关键字所在列C

  • C=1时,按照id升序排列,输出信息
  • C=2时,按照姓名字母序升序排列,如果两个人姓名相同,则按照id升序排列输出
  • C=3时,按照成绩升序排列,如果两个人成绩相等,则按照id升序排列输出

思路

写三个排序函数,构造结构体person即可

代码

#include<bits/stdc++.h>
using namespace std;
struct person{
    int id, score;
    string name;
};
bool cmp1(const person& a, const person& b){ return a.id < b.id; }
bool cmp2(const person& a, const person& b){
    return a.name == b.name ? a.id < b.id : a.name < b.name;
}
bool cmp3(const person& a, const person& b){
    return a.score == b.score ? a.id < b.id : a.score < b.score;
}
int main(){
    int N, C;
    cin>>N>>C;
    person p;
    vector<person> v(N);
    for(int i=0; i<N; i++)
        cin>>v[i].id>>v[i].name>>v[i].score;
    if(C == 1)
        sort(v.begin(), v.end(), cmp1);
    else if(C == 2)
        sort(v.begin(), v.end(), cmp2);
    else if(C == 3)
        sort(v.begin(), v.end(), cmp3);
    for(auto it : v){
        printf("%06d %s %d\n",it.id, it.name.c_str(), it.score);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值