Problem A: 求个最大值
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 1635 Solved: 1339
[ Submit][ Status][ Web Board]
Description
定义MaxValue类,用于求一系列非零整数的最大值。其中:
1. 数据成员elements用于存储所有输入的非零整数。
2. void append(int)用于向elements中添加一个新数据。
3. int getMax()用于求出elements中的最大值。
Input
输入若干个整数,以输入0表示输入结束。
Output
所有输入的非零整数中的最大值。
Sample Input
3214965533388374631581549295370
Sample Output
929
HINT
使用vector更为容易实现。
Append Code
#include<bits/stdc++.h>
using
namespace
std;
class
MaxValue{
private
:
vector <
int
> elements;
public
:
void
append(
int
n)
{
elements.push_back(n);
}
int
getMax()
{
vector<
int
>::iterator max ;
max= max_element(elements.begin(), elements.end());
return
*max;
}
};
int
main()
{
int
a;
MaxValue test;
cin>>a;
while
(a != 0)
{
test.append(a);
cin>>a;
}
cout<<test.getMax()<<endl;
return
0;
}