PAT 1066 Root of AVL Tree (25分) (AVL模板)

本文详细介绍了AVL树的基本概念,包括其自我平衡的特性,即任意节点的两个子树高度差不超过1。通过一系列旋转操作(左旋、右旋、左右旋和右左旋),确保在插入新节点后,AVL树仍保持平衡状态。文章还提供了实现AVL树插入和平衡调整的代码示例,帮助读者理解AVL树的工作原理。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1066 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

题目大意:求avl树根的值

推荐一个AVL学习博客:https://www.cnblogs.com/WindSun/p/11379670.html

代码:

//AVL:平衡二叉搜索树
//AVL的代码模板 
#include <bits/stdc++.h>
using namespace std;
struct Node{
	int val;
	struct Node *left, *right;
};  
//左旋
/*
  .
   .
    .
*/ 
Node *leftRotate(Node *rt){
	Node *temp = rt->right;
	rt->right = temp->left;
	temp->left = rt;
	return temp;
} 
//右旋
/*
    .
   .
  .	
*/ 
Node *rightRotate(Node *rt){
	Node *temp = rt->left;
	rt->left = temp->right;
	temp->right = rt;
	return temp;
} 
//先左再右旋
/*
    .                 .    
   .  <- 左旋   -->  .
    .	            .  
*/ 
Node *leftRightRotate(Node *rt){
	rt->left = leftRotate(rt->left);
	return rightRotate(rt); 
}
//先右再左旋
/*
    .                .
     . <- 右旋  -->   .
    .                  .
*/
Node *rightLeftRotate(Node *rt){
	rt->right = rightRotate(rt->right);
	return leftRotate(rt); 
}
//高度
int getHg(Node *rt){
	if( rt == NULL) return 0;
	return max(getHg(rt->left), getHg(rt->right)) + 1;
} 
//插入 构造AVL
Node *insert(Node *rt, int val){
	if(rt == NULL){
		rt = new Node();
		rt->val = val;
		rt->right = rt->left = NULL; 
	}else if(val < rt->val ){
		rt->left = insert(rt->left, val);
		if(getHg(rt->left) - getHg(rt->right) == 2){
			rt = val < rt->left->val ? rightRotate(rt) : leftRightRotate(rt);
		}
	}else {
		rt->right = insert(rt->right, val);
		if(getHg(rt->left) - getHg(rt->right) == -2){
			rt = val > rt->right->val ? leftRotate(rt) : rightLeftRotate(rt);
		}
	}
	return rt;
}
int main(){
	int n, v;
	cin >> n;
	Node *rt = NULL;
	for(int i = 0; i < n; i++){
		cin >> v;
		rt = insert(rt, v);
	} 
	cout << rt->val << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值