【ZCMU2993】Fibonacci-ish(暴力dfs+map使用)

题目链接

2993: Fibonacci-ish

Time Limit: 2 Sec  Memory Limit: 256 MB
Submit: 30  Solved: 13
[Submit][Status][Web Board]

Description

D. Fibonacci-ish

Yash has recently learnt about the Fibonacci sequence and is very excited about it. He calls a sequence Fibonacci-ish if

  1. the sequence consists of at least two elements
  2. f0 and f1 are arbitrary
  3. fn+2=fn+1+fn for all n≥0.

You are given some sequence of integers a1,a2,...,an. Your task is rearrange elements of this sequence in such a way that its longest possible prefix is Fibonacci-ish sequence.

Input

 The first line of the input contains a single integer n (2≤n≤1000)− the length of the sequence ai.

The second line contains n integers a1,a2,...,an (|ai|≤109).

Output

 Print the length of the longest possible Fibonacci-ish prefix of the given sequence after rearrangement.

Sample Input

3

1 2 -1

Sample Output

3

HINT

 

 In the first sample, if we rearrange elements of the sequence as -1, 2, 1, the whole sequence ai would be Fibonacci-ish.

 

【题意】

已知n个数,构造一个最长的符合斐波那契的数列,输出最长的长度。

 

【解题思路】

直接暴力枚举前两个数,用m1记录每个数出现的次数,m2记录前两个数是否已经搜索过,注意回溯,并且注意最后答案需要+2。因为题中已经明确这个序列至少存在两个数,所以不存在序列(1 5 9)。

 

【代码】

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e3+5;
int a[maxn];
map<int,int>m1;
map<pair<int,int>,int>m2;
int dfs(int x,int y)
{
    if(!m1[x+y])return 0;
    m1[x+y]--;
    int ans=dfs(y,x+y)+1;
    m1[x+y]++;
    return ans;
}
int main()
{
    int n,ans=0;
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
        m1[a[i]]++;
    }
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            if(i==j)continue;
            if(m2[make_pair(a[i],a[j])])continue;
            m2[make_pair(a[i],a[j])]=1;
            m1[a[i]]--;
            m1[a[j]]--;
            ans=max(ans,dfs(a[i],a[j]));
            m1[a[i]]++;
            m1[a[j]]++;
        }
    }
    printf("%d\n",ans+2);
    return 0;
}

 

当前提供的引用内容并未提及 ZCMU OJ 的题目编号 52131。因此无法直接通过现有引用获取其具体细节或解决方案[^4]。 通常情况下,在解决 OJ 平台上的问题时,可以遵循以下方法来分析和解决问题: ### 题目解析流程 #### 数据结构与算法的选择 对于未明确描述的题目,可以根据常见题型推测可能涉及的数据结构和算法。例如: - 如果涉及到字符串操作,则需考虑大小写敏感性以及特殊字符处理[^1]。 - 若为图论相关问题(如 Domino 倒下模拟),则可采用并查集或其他连通性算法进行求解[^2]。 - 对于最大子数组和等问题,动态规划可能是有效的工具之一[^3]。 以下是基于假设的一个通用框架用于解决潜在类似的编程挑战: ```python def solve_problem(input_data): """ 解决特定输入数据下的计算逻辑 参数: input_data (list): 输入参数列表 返回值: result : 计算后的结果 """ # 初始化变量 n = len(input_data) # 动态规划表初始化 dp = [0]*n dp[0] = max_sum = input_data[0] for i in range(1,n): # 更新状态转移方程 dp[i] = max(dp[i-1]+input_data[i], input_data[i]) # 跟踪全局最优解 if dp[i]>max_sum: max_sum=dp[i] return max_sum ``` 此代码片段仅作为示范用途,并不一定适用于实际编号为 `52131` 的题目情境。 ### 注意事项 当面对新类型的竞赛题目时,请务必仔细阅读原题说明文档,理解边界条件、时间复杂度需求等因素后再着手编写程序实现方案。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值