ZCMU 1040: 二哥的困惑 Ⅲ

本文介绍了一种特殊卡牌游戏的最优策略,玩家需在每轮比赛中选择一张卡牌进行比拼,目标是在限定轮次中赢得尽可能多的回合。通过将问题抽象为一种策略选择问题,并采用类似田忌赛马的策略来确定至少可以赢得的回合数。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

Suppose there are M people, including you, playing a special card game. At the beginning, each player receives N cards. The pip of a card is a positive integer which is at most N*M. And there are no two cards with the same pip. During a round, each player chooses one card to compare with others. The player whose card with the biggest pip wins the round, and then the next round begins. After N rounds, when all the cards of each player have been chosen, the player who has won the most rounds is the winner of the game.

Given your cards received at the beginning, write a program to tell the maximal number of rounds that you may at least win during the whole game. 
Input


The input consists of several test cases. The first line of each case contains two integers m (2<=m<=20) and n (1<=n<=50), representing the number of players and the number of cards each player receives at the beginning of the game, respectively. This followed by a line with n positive integers, representing the pips of cards you received at the beginning. Then a blank line follows to separate the cases. 

The input is terminated by a line with two zeros. 

Output


For each test case, output a line consisting of the test case number followed by the number of rounds you will at least win during the game. 

Sample Input
2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0
Sample Output
Case 1: 2
Case 2: 4

【分析】这题和田忌赛马https://blog.youkuaiyun.com/qq_39315193/article/details/81563882解题思路相同,更简单

虽然是多人游戏,如果把其他人看成一队,全针对自己,这样就能保证我赢的是最少的。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int a[1005], b[1005];
bool cmp(int a, int b)
{
    return a > b;
}
int main()
{
    int m,n ;
    int count = 0;
    while(scanf("%d%d",&m,&n))
    {
        if(m==0&&n==0)break;
        count++;
        memset(a , 0 ,sizeof(a));
        int t = 0,win = 0;;
        for(int i =0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a, a + n, cmp);//自己牌a[]降序排列
        for(int i = n*m,j=0;i>0;i--)
        {
            if(i==a[t])
            {
                t++;
                continue;
            }
            b[j] = i;
            j++;
        }//对面牌b[]降序排列

        for(int i = 0,j =0;i<n;i++)//我从大往小出牌
        {
            if(b[j]>a[i])//对手最大的牌能大于我的牌,对面就出最大的(换个理解就是对面用最大的牌耗我最大的牌)
                j++;                                               
            else
                win++;//对面最大的牌小于我的最大的牌,对面就出最小的,j不变表示最大的牌留着
                      //因为不存在两张牌相同,所以不必考虑最小牌耗我的最小牌的情况(当对手最小牌大于我的最小牌)
        }
        printf("Case %d: %d\n" ,count ,win);
    }
    return 0;
}

这篇解题思路很好https://blog.youkuaiyun.com/abcjennifer/article/details/5405097

当前提供的引用内容并未提及 ZCMU OJ 的题目编号 52131。因此无法直接通过现有引用获取其具体细节或解决方案[^4]。 通常情况下,在解决 OJ 平台上的问题时,可以遵循以下方法来分析和解决问题: ### 题目解析流程 #### 数据结构与算法的选择 对于未明确描述的题目,可以根据常见题型推测可能涉及的数据结构和算法。例如: - 如果涉及到字符串操作,则需考虑大小写敏感性以及特殊字符处理[^1]。 - 若为图论相关问题(如 Domino 倒下模拟),则可采用并查集或其他连通性算法进行求解[^2]。 - 对于最大子数组和等问题,动态规划可能是有效的工具之一[^3]。 以下是基于假设的一个通用框架用于解决潜在类似的编程挑战: ```python def solve_problem(input_data): """ 解决特定输入数据下的计算逻辑 参数: input_data (list): 输入参数列表 返回值: result : 计算后的结果 """ # 初始化变量 n = len(input_data) # 动态规划表初始化 dp = [0]*n dp[0] = max_sum = input_data[0] for i in range(1,n): # 更新状态转移方程 dp[i] = max(dp[i-1]+input_data[i], input_data[i]) # 跟踪全局最优解 if dp[i]>max_sum: max_sum=dp[i] return max_sum ``` 此代码片段仅作为示范用途,并不一定适用于实际编号为 `52131` 的题目情境。 ### 注意事项 当面对新类型的竞赛题目时,请务必仔细阅读原题说明文档,理解边界条件、时间复杂度需求等因素后再着手编写程序实现方案。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值