Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
创建比较器实现Comparator接口
先对各考场考生分别排序得到考生的考场内排名,再对所有考生排序得到总排名。
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;
class Student{
String id;
int localRank,grade,locationNo;
}
class Cmp implements Comparator<Student>{
@Override
public int compare(Student o1, Student o2) {
if(o1.grade!=o2.grade)
return o1.grade>o2.grade?-1:1;//降序排序
// return o2.grade-o1.grade;
return o1.id.compareTo(o2.id);//升序排序
}
}
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));
// Scanner sc=new Scanner(System.in);
int N=Integer.valueOf(reader.readLine()),num=0;//num记录学生个数
String[] line=null;
Student[] stu=new Student[30001];
for(int i=1;i<=N;i++) {
int K=Integer.valueOf(reader.readLine());
for(int j=0;j<K;j++) {
line=reader.readLine().split(" ");
stu[num]=new Student();
stu[num].id=line[0];
stu[num].grade=Integer.valueOf(line[1]);
stu[num].locationNo=i;
num++;//考生数+1
}
//考场内排序(左闭右开)
Arrays.sort(stu,num-K,num,new Cmp());
//记录考场内排名
stu[num-K].localRank=1;
for(int j=num-K+1;j<num;j++) {
if(stu[j].grade!=stu[j-1].grade)//若与前一位不同分则排名为下标
stu[j].localRank=j-(num-K)+1;
else//若与前一位同分则排名不变
stu[j].localRank=stu[j-1].localRank;
}
}
System.out.println(num);
//所有考生排序
Arrays.sort(stu,0,num,new Cmp());
//计算总排名
int r=1;
for(int i=0;i<num;i++) {
if(i>0&&stu[i].grade!=stu[i-1].grade)
r=i+1;//排名更新
System.out.println(stu[i].id+" "+r+" "+stu[i].locationNo+" "+stu[i].localRank);
}
}
}