PAT 1027 Colors in Mars (20 分)

本文介绍了一个算法,用于将地球上的RGB颜色值转换为火星上使用的基数13的颜色表示方法。通过解析输入的三个十进制颜色值,将其转换为火星RGB格式,并确保输出符合特定的格式要求。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456
#include<iostream>
#include<string>
#include<sstream>
#include<vector>
#include<algorithm>
#include<cmath>
using namespace std;
//9:57

int main()
{
	//freopen("C:\\Users\\chenzhuo\\Desktop\\in.txt","r",stdin);
	
	int a[3];
	cin>>a[0]>>a[1]>>a[2];
	char tmp[]={'0','1','2','3','4','5','6','7','8','9','A','B','C'};
	cout<<'#';
	string a1[3]={"","",""};
	for(int i=0;i<3;i++)
	{
		do
		{
			char k=tmp[a[i]%13];
			a1[i]=k+a1[i];
			a[i]/=13;
		}while(a[i]>0);
	}
	for(int i=0;i<3;i++)
	{
		if(a1[i].size()==1) a1[i]='0'+a1[i];
		cout<<a1[i];
	}
	
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值