hdoj 1719 Friend(公式)

Friend(链接)

Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
   
   
3 13121 12131
 

Sample Output
   
   
YES! YES! NO!

注: (1)1和2是友好数
(2)如果 a 和 b 都是友好数的话  a*b+a+b 也是友好数
嗯嗯嗯:
当 c = 0 是直接输出 NO!!!!!!!!别忘记感叹号
令 c = a*b+a+b;注意到(a + 1)*(b + 1)= c + 1;
所以 c + 1 不断除以2 然后除以3 得到的结果如果是1的话 c 就是完美数

#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
        {
            printf("NO!\n");
            continue;
        }
        n++;
        while(n%2==0)
            n/=2;
        while(n%3==0)
            n/=3;
        if(n==1)
            printf("YES!\n");
        else
            printf("NO!\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值