Balancing Act
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 15486 | Accepted: 6552 |
Description
Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:
Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.
For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.
For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.
Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.
Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.
Sample Input
1 7 2 6 1 2 1 4 4 5 3 7 3 1
Sample Output
1 2
Source
/*求树的重心:若树上一个节点满足其所有子树中最大的子树的节点数最少,那么这个点,就是这颗树的重心
自底往上dfs,分别求出儿子方向子树节点数,在求和就可以得到父亲节点方向的子树节点个数=n-num[v];
*/
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define INF 0x3f3f3f3f
#define N 210000
struct node {
int u, v;
int w;
int next;
}edge[N*20];
int n;
int num[N], dp[N];
int mini, pos;
int head[N], cnt;
void addedge(int u, int v)
{
edge[++cnt].u = u;
edge[cnt].v = v;
//edge[cnt].w = w;
edge[cnt].next = head[u];
head[u] = cnt;
}
void dfs(int u, int pre)
{
num[u] = 1;
dp[u] = -1;
if(u==2)
int t = 1;
for(int i = head[u]; ~i; i = edge[i].next) {
int v = edge[i].v;
if(v == pre)
continue;
dfs(v, u);
num[u] += num[v];
dp[u] = max(dp[u], num[v]);
}
dp[u] = max(dp[u], n-num[u]);
if(dp[u] <= mini) {
if(dp[u]<mini || (dp[u]==mini && u<pos))
pos = u;
mini = dp[u];
}
}
int main(int argc, char const *argv[])
{
int T;
scanf("%d", &T);
int u, v;
while(T--) {
scanf("%d", &n);
for(int i = 0; i <= n; i++)
head[i] = -1;
cnt = 0;
for(int i = 1; i <= n-1; i++) {
scanf("%d%d", &u, &v);
addedge(u, v);
addedge(v, u);
}
mini = INF;
pos = n;
dfs(1, 0);
printf("%d %d\n", pos, mini);
}
return 0;
}