Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 42382 | Accepted: 17805 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
Source
从1开始,每次递归递归两条线路
x*10和x*10+1
1可以变成 10 和 11
直到它可以整除n,递归19层左右。
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
#define LL long long
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN = 205;
const int INF = 0x3f3f3f3f;
LL vis[205];
LL n;
int flag;
void dfs(int x,LL num)
{
if(x>=19) return ;
if(flag==1) return;
if(num%n==0)
{
flag = 1;
printf("%lld\n",num);
return ;
}
dfs(x+1,num*10);
dfs(x+1,num*10 + 1);
}
int main()
{
while(scanf("%lld",&n)&&n!=0)
{
flag = 0;
M(vis,0);
dfs(0,1);
}
return 0;
}