K - The kth great number
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an ” I” followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.
Output
The output consists of one integer representing the largest number of islands that all lie on one line.
Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
Sample Output
1
2
3
思路:对刚开始输入的k个数用sort进行排序,在这之后,因为数列刚开始就已经比较的有序了,那么插入一 个数之后如果再用sort来排序就比较的浪费时间了,可以采用插入排序,只需要进行比较将 其控制为插入到第一个大于这个数之前的那个位置即可,将其前面的都往前挪一位.
AC代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include<functional>
using namespace std;
int a[1000005];
int main()
{
int n,k;
char s;
while(scanf("%d %d",&n,&k) == 2)
{
int cnt = 0;
for(int i = 0; i < k; i++)
{
scanf(" %c",&s);
if(s == 'I')
scanf("%d",&a[cnt++]);
}
int b;
sort(a,a+k);//刚开始的排序
for(int j = k; j < n; j++)
{
scanf(" %c",&s);
if(s == 'I')
{
scanf("%d",&b);
if(b > a[0])
{
int i1;
for(i1 = 0; i1 < k; i1++)
{
if(a[i1] >= b)
{
break;
}
}
for(int j1 = 0; j1 <i1-1; j1++)
a[j1] = a[j1+1];
a[i1-1] = b;
}
}
else
printf("%d\n",a[0]);
}
}
return 0;
}