Description
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
- Choose any one of the 16 pieces.
- Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.
Input
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
Output
Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
Sample Input
bwwb bbwb bwwb bwww
Sample Output
4
题意:黑白棋,4*4的棋盘,翻转一个周围四个都翻转(如果有的话),问最少翻转几步;
思路:枚举+bfs,翻转的次数在0~16之间,那么把0~16的每种情况枚举出来再深搜就行了;
ps:这道题还可以用广搜+位运算做;
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[10][10];
int count;
bool flag;
void is()
{
for(int i=0; i<4; i++)
{
for(int j=0; j<4; j++)
{
if(s[0][0]!=s[i][j])
{
flag=false;
return;
}
}
}
flag=true;
}
void change(int x,int y)
{
s[x][y]='b'+'w'-s[x][y];
if(x-1>=0) s[x-1][y]='b'+'w'-s[x-1][y];
if(x+1<4) s[x+1][y]='b'+'w'-s[x+1][y];
if(y-1>=0) s[x][y-1]='b'+'w'-s[x][y-1];
if(y+1<4) s[x][y+1]='b'+'w'-s[x][y+1];
}
void bfs(int x,int y,int n)
{
if(n==count) is();
if(x>=4||flag) return;
change(x,y);
if(y==3)
{
bfs(x+1,0,n+1);
change(x,y);
bfs(x+1,0,n);
}
else
{
bfs(x,y+1,n+1);
change(x,y);
bfs(x,y+1,n);
}
}
int main()
{
flag=false;
for(int i=0; i<4; i++) scanf("%s",s[i]);
for(int i=0; i<=16; i++)
{
count=i;
bfs(0,0,0);
if(flag) break;
}
if(flag) printf("%d\n",count);
else printf("Impossible\n");
return 0;
}