This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 3 3.6 2 6.0 1 1.6
题意:简单的多项式乘法
思路:一个个乘就好了,这里我并不能完全通过,在牛客网上的测试数据中我发现了自己的问题,就是在多项式的系数相乘过程中,丢失精度,导致最后的一个数据出现0.1的误差,由于水平有限,暂时不知改如何解决
下面是部分AC代码
#include <stdio.h>
struct Node {
int exp;
double coe;
} Poly1[1005], Poly2[1005];
double Poly3[2010];
int n, m;
int main()
{
//初始化
for(int i=0;i<2010;i++)
Poly3[i] = -1;
//输入
scanf("%d", &n);
for (int i = 0; i < n; i++)
scanf("%d %lf", &Poly1[i].exp, &Poly1[i].coe);
scanf("%d", &m);
for(int i=0;i<m;i++)
scanf("%d %lf", &Poly2[i].exp, &Poly2[i].coe);
int count = 0;
//计算
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
int temp_exp = Poly1[i].exp + Poly2[j].exp;
double temp_coe = Poly1[i].coe * Poly2[j].coe;
if (Poly3[temp_exp] == -1)
{
count++;
Poly3[temp_exp] = temp_coe;
}
else
{
Poly3[temp_exp] += temp_coe;
}
}
}
//输出
printf("%d", count);
for (int i = 2009; i >= 0; i--)
{
if (Poly3[i] != -1)
{
printf(" %d %.1f", i, Poly3[i]);
}
}
return 0;
}