hdu 1062 Text Reverse

本文介绍了一个简单的字符串处理问题,即如何将输入的一行文本中的单词逆序输出。通过使用C++实现,文章提供了一段AC代码,展示了如何读取多组测试数据并逐个单词进行逆序处理。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1062

 

题目描述:

 

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

 

 

Output

For each test case, you should output the text which is processed.

 

 

Sample Input

 

3 olleh !dlrow m'I morf .udh I ekil .mca

 

 

Sample Output

 

hello world! I'm from hdu. I like acm.

 

 

 

 

题目分析:

题目本身并不是什么难的题目,但是我在这里写的原因是觉得字符串处理真的非常重要,所以还是多写几遍比较好

 

AC代码:

 

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
using namespace std;
int n;
char s[1005];
int main()
{
    cin>>n;
    getchar();
    while(n--)
    {
        gets(s);
        int l=strlen(s);
        for(int i=0;i<l;)
        {
            if(s[i]==' ')
                {
                    printf("%c",s[i]);
                    i++;
                    continue;
                }
            while(s[i]!=' '&&i<l)
                i++;
            for(int j=i-1;s[j]!=' '&&j>=0;j--)
                {
                    printf("%c",s[j]);
                }
        }
        printf("\n");
    }
    return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值