POJ 1651

Multiplication Puzzle

description:

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.
The goal is to take cards in such order as to minimize the total number of scored points.
For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650


题目大意:
给出一个序列 a[n] ,从中依次选出n-2个数(除了第一个 和 最后一个),每次选出一个数ai后获得 a[i-1]*a[i]*a[i+1]的得分,求最大可以获得多少得分。

解题思路: 
1.假设f[i][j]为选掉了i~j号数以后能获得的最大收益。(i选取,而j不选取)
2.f[i][j] = max( f[i][j] , f[i][k]+f[k+1][j]]+a[i-1]*a[k]*a[j]) 此处f[i][k]表示将[i,k)号数选取以后能获得的最大收益,f[k+1][j]表示将[k+1,j)数选取以后能获得的最大收益,此时再将最后一个可以选数a[k]选取,获得收益 a[i-1]*a[k]*a[j]。
3.由于选取区间是前闭后开的,求问题的解调用的是f[2][n]


源代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
using namespace std;

int n,times;
int a[105];
int f[105][105];

int main(){
    while(~scanf("%d",&n)){
        memset(f,0,sizeof(f));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int l = 2; l<n; l++){  
           for(int i = 2; i+l<=n+1; i++){  
                int j = i+l-1;  
                f[i][j] = 100000005;  
                for(int len = i; len<j; len++)
                   f[i][j] = min(f[i][j],f[i][len]+f[len+1][j]+a[i-1]*a[len]*a[j]);  
            }  
        }  
        printf("%d\n",f[2][n]);  

    }
    return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值