POJ - 1222 EXTENDED LIGHTS OUT高斯消元

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source


这题可以利用枚举法做,本人比较懒就不打了,我写的是高斯消元的方法,就是线性代数中一个解方程组的方法。

就是说我们可以把本题看成是,灯一开始是全灭的,经过数次按键之后达到我们想要的状态,对于每一个灯每一个按扭有可能使其转换状态,也可能不能,那么能转换的记为1,不能的记为0,相当于ax+by+cz.....=l,l表示灯的状态(记得用亦或运算),这样对每一个灯我们就可以列出一个1*31的方程,总共有三十个灯就可以得到一个30*31的方程组,然后就是利用高斯消元解方程组了。解出来的那些系数就是结果。

下面是我的代码,因为我觉得本题每一个按键按与不按都是确定的,所以把高斯校园标准的模板中的一些东西删去了。但是是可以AC的。至于 完整的模板你们可以上网找,作为水牛的我就不提供了。

#include <stdio.h>
#include<algorithm>
#include <string.h>
using namespace std;

int a[40][40];
int ans[40];

void init()
{
	memset(a,0,sizeof(a));
	int i,j,k;
	for(i=0;i<5;i++)
		for(j=0;j<6;j++)
		{
			k=i*6+j;
			a[k][k]=1;
			if(i>0)
				a[k-6][k]=1;
			if(i<4)
				a[k+6][k]=1;
			if(j>0)
				a[k-1][k]=1;
			if(j<5)
				a[k+1][k]=1;
		}
}

void Gauss()
{
	int i,j,k,l;
	for(i=0;i<30;i++)
	{
		for(j=i;j<30;j++)
		{
			if(a[j][i]==1)
				break;
		}
		if(j!=i)
			for(k=0;k<=30;k++)
				swap(a[i][k],a[j][k]);
		for(k=j+1;k<30;k++)
			if(a[k][i])
				for(l=0;l<=30;l++)
					a[k][l]^=a[i][l];
	}
	for(i=29;i>=0;i--)
	{
		ans[i]=a[i][30];
		for(j=i+1;j<30;j++)
		{
			ans[i]^=(a[i][j]&&ans[j]);
		}
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	int icase;
	for(icase=1;icase<=t;icase++)
	{
		init();
		int i,j,k;
		for(i=0;i<30;i++)
			scanf("%d",&a[i][30]);
		Gauss();
        printf("PUZZLE #%d",icase); 
		for(i=0;i<30;i++)
		{
			if(i%6==0)
				printf("\n%d",ans[i]);
			else
				printf(" %d",ans[i]);
		}
       printf("\n");
	}
	return 0;
}


python+opencv简谱识别音频生成系统源码含GUI界面+详细运行教程+数据 一、项目简介 提取简谱中的音乐信息,依据识别到的信息生成midi文件。 Extract music information from musical scores and generate a midi file according to it. 二、项目运行环境 python=3.11.1 第三方库依赖 opencv-python=4.7.0.68 numpy=1.24.1 可以使用命令 pip install -r requirements.txt 来安装所需的第三方库。 三、项目运行步骤 3.1 命令行运行 运行main.py。 输入简谱路径:支持图片或文件夹,相对路径或绝对路径都可以。 输入简谱主音:它通常在第一页的左上角“1=”之后。 输入简谱速度:即每分钟拍数,同在左上角。 选择是否输出程序中间提示信息:请输入Y或N(不区分大小写,下同)。 选择匹配精度:请输入L或M或H,对应低/中/高精度,一般而言输入L即可。 选择使用的线程数:一般与CPU核数相同即可。虽然python的线程不是真正的多线程,但仍能起到加速作用。 估算字符上下间距:这与简谱中符号的密集程度有关,一般来说纵向符号越稀疏,这个值需要设置得越大,范围通常在1.0-2.5。 二值化算法:使用全局阈值则跳过该选项即可,或者也可输入OTSU、采用大津二值化算法。 设置全局阈值:如果上面选择全局阈值则需要手动设置全局阈值,对于.\test.txt中所提样例,使用全局阈值并在后面设置为160即可。 手动调整中间结果:若输入Y/y,则在识别简谱后会暂停代码,并生成一份txt文件,在其中展示识别结果,此时用户可以通过修改这份txt文件来更正识别结果。 如果选择文件夹的话,还可以选择所选文件夹中不需要识别的文件以排除干扰
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值