HDU2051(栈)Bitset

Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 10 11
 

一直都没怎么用过数据结构,这道题可以用数组,但想了想很符合栈,就用栈写了下

#include <iostream>
#include <cstdio>
#include <stack>

using namespace std;
int main()
{
	int n;
	while(~scanf("%d", &n))
	{
		stack<int> s;
		while(n > 1)
		{
			s.push(n % 2);
			n = n/2;
		}
		printf("1");
		while(!s.empty())
		{
			printf("%d", s.top());
			s.pop();
		}
		printf("\n");
	}
	
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值