hduoj 2147 kiki's game(巴什博弈)

本文介绍了一种基于组合博弈论的简单游戏,游戏的目标是在一个n*m的棋盘上通过移动一枚硬币来决定胜负。文章详细解释了游戏规则及如何通过分析必胜点和必败点来确定游戏的最终赢家。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

kiki's game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/10000 K (Java/Others)
Total Submission(s): 9890    Accepted Submission(s): 5973


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
  
  
5 3 5 4 6 6 0 0
 


Sample Output
   
   
What a pity! Wonderful! Wonderful!

【题目分析】

一切博弈都是找规律:

题目的意思是从棋盘的最右上角到左下角,其中只可以走三个方向, 左边, 下边,右边,不能移动着失败,问先手是否胜利
根据博弈论的理论,先从左下角开始分析

博弈论:组合博弈
必败点(P点) :前一个选手(Previous player)将取胜的位置称为必败点。
必胜点(N点) :下一个选手(Next player)将取胜的位置称为必胜点。
必败(必胜)点的属性:
(1) 所有终结点是必败点(P点);
(2) 从任何必胜点(N点)操作,至少有一种方法可以进入必败点(P点);
(3)无论如何操作, 从必败点(P点)都只能进入必胜点(N点).
 由上面的属性得到该题的算法:

步骤1:将所有终结位置标记为必败点(P点);
步骤2: 将所有一步操作能进入必败点(P点)的位置标记为必胜点(N点)
步骤3:如果从某个点开始的所有一步操作都只能进入必胜点(N点) ,则将该点标记为必败点(P点) ;
步骤4: 如果在步骤3未能找到新的必败(P点),则算法终止;否则,返回到步骤2。
   由上面的算法计算一个例子:
我们可以把问题转换成从(1,1)走到(n,m) (方便等下得出结论)
但n=8,m=9的情况
 NNNNNNNNN
 PNPNPNPNP
 NNNNNNNNN
 PNPNPNPNP
 NNNNNNNNN
 PNPNPNPNP
 NNNNNNNNN
 PNPNPNPNP
初始点(1,1)为N所以输出Wonderful!
从这里例子就可以很清楚得看出当n和m都为奇数时,初始点(1,1)才会是P。
因此该题只需判断n,m是否同时为奇数即可。



AC代码:
#include<stdio.h>
int main()
{
  int n,m;
  while(scanf("%d%d",&n,&m)!=EOF&&n!=0&&m!=0)
  {
     if(m&1&&n&1)
          printf("What a pity!\n");
     else
          printf("Wonderful!\n");//行数或者列数为偶数就赢 
  }
  return 0;
}
Sample Output
   
   
What a pity! Wonderful! Wonderful!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值