树的遍历
时间限制 400 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序 Standard
作者 陈越
给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
输出样例:
4 1 6 3 5 7 2
#include<cstdio>
#include<cstring>
#include<iostream>
#include<map>
#include<algorithm>
#include<queue>
using namespace std;
int a[35],b[35];
map<int,int>L,R;
int build(int la,int ra,int lb,int rb)
{
if(la>ra)
return 0;
int root=a[ra];
int i;
for(i=lb;i<=rb&&b[i]!=root;i++);
if(i<=rb)
{
R[root]=build(ra-rb+i,ra-1,i+1,rb);
L[root]=build(la,ra-rb+i-1,lb,i-1);
}
return root;
}
void bfs(int root)
{
queue<int>q;
q.push(root);
int flag=0;
while(!q.empty())
{
int f=q.front();
q.pop();
if(flag)
{
cout<<' '<<f;
}
else
{
cout<<f;
flag++;
}
if(L[f])
{
q.push(L[f]);
}
if(R[f])
{
q.push(R[f]);
}
}
cout<<endl;
}
int main()
{
int n;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>a[i];
}
for(int i=1;i<=n;i++)
{
cin>>b[i];
}
int root;
root=build(1,n,1,n);
bfs(root);
return 0;
}
玩转二叉树
时间限制 400 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序 Standard
作者 陈越
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
时间限制 400 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序 Standard
作者 陈越
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。
输入格式:
输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。
输出格式:
在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。
输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2
#include<cstdio>
#include<cstring>
#include<iostream>
#include<map>
#include<algorithm>
#include<queue>
using namespace std;
int a[35],b[35];
map<int,int>L,R;
int build(int la,int ra,int lb,int rb)
{
if(lb>rb)
return 0;
int root=b[lb];
int i;
for(i=la;i<=ra&&a[i]!=root;i++);
if(i<=ra)
{
R[root]=build(i+1,ra,lb-la+i+1,rb);
L[root]=build(la,i-1,lb+1,rb-ra+i);
}
return root;
}
void bfs(int root)
{
queue<int>q;
q.push(root);
int flag=0;
while(!q.empty())
{
int f=q.front();
q.pop();
if(flag)
{
cout<<' '<<f;
}
else
{
cout<<f;
flag++;
}
if(R[f])
{
q.push(R[f]);
}
if(L[f])
{
q.push(L[f]);
}
}
cout<<endl;
}
int main()
{
int n;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>a[i];
}
for(int i=1;i<=n;i++)
{
cin>>b[i];
}
int root;
root=build(1,n,1,n);
bfs(root);
return 0;
}