UVA-621 Secret Research

UVA-621 Secret Research

题目大意:判断所输入的是哪一种

  • positive result S = 1 or S = 4 or S = 78
  • negative result S = S35
  • experiment failed S = 9S4
  • experiment not completed S = 190S

    for a positive result +
    for a negative result -
    for a failed experiment *
    for a not completed experiment ?

Sample Input

4
78
7835
19078
944

Sample Output

+

?
*

解题思路:分四种判断

//UVA- 621 Secret Research
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
using namespace std;

int main() {
    int T;
    scanf("%d",&T);
    while (T--) {
        string s;
        cin >> s;
        int len = s.length();
        if (s == "4" || s == "1" || s == "78")
//      if (strcmp(s,"4") == 0 || strcmp(s,"1") == 0 || strcmp(s,"78") == 0)  //string 类型重载了 += 和 == ,不能用字符串中的 strcmp 函数
            puts("+");
        else if (s[len - 1] == '5' && s[len -2] == '3')
            puts("-");
        else if (s[len - 1] == '4' && s[0] == '9')
            puts("*");
        else if (s[0] == '1' && s[1] == '9' && s[2] == '0')
            puts("?");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值