Description
Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:
Your task is to calculate d(A).
Input
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.
Output
Print exactly one line for each test case. The line should contain the integer d(A).
Sample Input
1
10
1 -1 2 2 3 -3 4 -4 5 -5
Sample Output
13
Hint
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.
Huge input,scanf is recommended.
code
#include <stdio.h>
#include <iostream>
using namespace std;
int a[50005], m[50005];
const int MIN = -999999999;
int main()
{
int c;
int n;
int i;
int temp, sum, ans;
scanf("%d", &c);
while(c--)
{
scanf("%d", &n);
temp = MIN;
sum = 0;
for(i = 1; i <= n; i++)
{
scanf("%d", &a[i]);
sum += a[i];
if(sum > temp) temp = sum;
m[i] = temp; // 记录每个字段的最大值。
if(sum < 0) sum = 0;
}
sum = 0;
temp = MIN;
ans = MIN;
for(i = n; i > 1; i--)
{
sum += a[i];
if(sum > temp) temp = sum;
ans = max(ans, temp + m[i-1]);
if(sum < 0) sum = 0;
}
printf("%d\n", ans);
}
return 0;
}