UVa 10299 :Relatives 欧拉函数

题目:
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n ≤ 1,000,000,000. A line containing ‘0’ follows the last case.
Output
For each test case there should be single line of output answering the question posed above.

Sample Input
7
12
0
Sample Output
6
4
题目大意:输入n,求出1到n(包括n)中与n互质的整数的个数,注意当n=1时,结果为0

解题方法:欧拉函数

欧拉函数的定义:
欧拉函数是少于或等于n的数中与n互质的数的数目,计算公式为
euler(x)=x(1-1/p1)(1-1/p2)(1-1/p3)(1-1/p4)…(1-1/pn)
其中p1,p2……pn为x的所有素因数,x是不为0的整数。

#include<iostream>//
using namespace std;
int euler(int n){//欧拉函数的实现
    int ans=n,i;
    if(n==1){
        return ans==0;
    }
    for(i=2;i*i<=n;i++){
        if(n%i==0){
            ans=ans/i*(i-1);
            while(n%i==0)
                n /= i;
         }
    }
    if(n>1)
        ans=ans/n*(n-1);
    return ans;
 }
 int main()
 {
    int n;
    while(cin>>n&&n!=0){
        cout<<euler(n)<<endl;
    }
    return 0;
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值