03-树3 Tree Traversals Again

本文详细介绍了如何通过非递归方式实现二叉树的前序遍历、中序遍历,并进一步阐述了如何利用这些遍历顺序生成后序遍历序列。通过实例分析,读者可以深入理解二叉树遍历的不同顺序及其转换原理。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
这里写图片描述
Figure 1
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 30≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to NN). Then 2N2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.
Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:

3 4 2 6 5 1

题目大意:从push进去顺序可以看出是先序遍历,从pop进去的顺序可以看出是中序遍历,现在要求后序遍历。

思路:只要知道中序和其余任一个,就可以知道另外一个遍历。现在是中序和先序,即一棵树先序的是第一个是后序的最后一个,然后再通过中序找到其左右子树,重复上述操作。

#include<iostream>
#include<string>
#include<vector>
#include<stack>

using namespace std;
int num;

void getpostorder(vector<int> preorder,int preL,vector<int> inorder,int inL,
    vector<int>& postorder,int postL,int n)
{
    if (n == 0) return;
    if (n == 1) {
        postorder[postL] = preorder[preL];
        return;
    }
     preorder[preL];
    postorder[postL + n - 1] = preorder[preL];
    //在中序遍历数组上找出root的位置
    int i = 0;
    while (i < n) {
        if (inorder[inL + i] == preorder[preL]) break;
        ++i;
    }

    int L = i, R = n - i - 1;


    getpostorder(preorder, preL + 1, inorder, inL, postorder, postL, L);
    getpostorder(preorder, preL + 1 + L, inorder, inL + L + 1, postorder, postL + L, R);
}


vector<vector<int>> getorder()
{
    cin >> num;

    vector<int> preOrder(num, 0);
    vector<int> inOrder(num, 0);
    stack<int> st;
    int pre = 0, in = 0;
    string temp;
    int data;
    for (int i = 0; i < 2 * num; i++)
    {
        cin >> temp;
        if (temp == "Push")
        {
            cin >> data;
            st.push(data);
            preOrder[pre++] = data;
        }

        else if (temp == "Pop")
        {
            inOrder[in++] = st.top();
            st.pop();
        }
    }

    return{ preOrder, inOrder };

}

int main()
{
    auto oredr = getorder();
    vector<int> postorder(num, 0);
    getpostorder(oredr[0], 0, oredr[1], 0, postorder, 0, num);
    int i = 0;
    for (; i < num-1; i++)
    {
        cout << postorder[i] << ' ';
    }
    cout << postorder[i];
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值