A Simple Problem with Integers

本文介绍了一种处理数组中特定区间加法操作及求和查询的高效算法实现。通过使用线段树数据结构,该算法能在对数时间内完成更新与查询操作,适用于需要大量区间修改与查询的应用场景。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >



Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C abc" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q ab" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<stack>
#include<algorithm>
#define INF 0x3f3f3f3f
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
const int maxn=100010;
int n,q;
long long sum[maxn<<2];
long long add[maxn<<2];

void Push_Up(int rt)
{
    sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}

void Push_Down(int rt,int m)
{
    if (add[rt])
    {
        add[rt<<1] += add[rt];
        add[rt<<1|1] += add[rt];
        sum[rt<<1] += add[rt] * (m - (m >> 1));
        sum[rt<<1|1] += add[rt] * (m >> 1);
        add[rt] = 0;
    }
}

void build(int l,int r,int rt)
{
    add[rt] = 0;
    if (l == r)
    {
        scanf("%I64d",&sum[rt]);
        return ;
    }
    int mid = (l + r) >> 1;
    build(lson);
    build(rson);
    Push_Up(rt);
}

void update(int L,int R,int c,int l,int r,int rt)
{
    if (L <= l && r <= R)
    {
        add[rt] += c;
        sum[rt] += (long long)c * (r - l + 1);
        return ;
    }
    Push_Down(rt , r - l + 1);
    int mid = (l + r) >> 1;
    if (L <= mid) update(L , R , c , lson);
    if (mid < R) update(L , R , c , rson);
    Push_Up(rt);
}

long long query(int L,int R,int l,int r,int rt)
{
    if (L <= l && r <= R)
    {
        return sum[rt];
    }
    Push_Down(rt , r - l + 1);
    int mid = (l + r) >> 1;
    long long ret = 0;
    if (L <= mid) ret += query(L , R , lson);
    if (mid < R) ret += query(L , R , rson);
    return ret;
}

int main()
{

    while(~scanf("%d%d",&n,&q))
    {
        build(1,n,1);
        char op[3];
        int a,b,c;
        while(q--)
        {
            scanf("%s",op);
            if (op[0] == 'Q')
            {
                scanf("%d%d",&a,&b);
                printf("%I64d\n",query(a , b , 1 , n , 1));
            }
            else
            {
                scanf("%d%d%d",&a,&b,&c);
                update(a , b , c , 1 , n , 1);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值