问题
1046 Shortest Distance (20 分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10
5
]), followed by N integer distances D
1
D
2
⋯ D
N
, where D
i
is the distance between the i-th and the (i+1)-st exits, and D
N
is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10
4
), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10
7
.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
结尾无空行
Sample Output:
3
10
7
结尾无空行
思路
一开始的想法是用floyd算法,但是发现题目所给结点数远远超过200,肯定会超时。于是采用暴力解法,发现还是会超时。原因在于数据没有预处理。
代码
#include<bits/stdc++.h>
using namespace std;
const int maxn = 100010;
int dis[maxn];
int n,m;
int main(){
cin>>n;
int temp,total = 0;
for (int i = 1; i <= n; ++i) {
cin>>temp;
total = total + temp;
dis[i] = total;
}
cin>>m;
int c1,c2;
for (int j = 0; j < m; ++j) {
cin>>c1>>c2;
int ans1,ans2;
if(c1<c2){
ans1 = dis[c2-1] - dis[c1-1];
ans2 = total - ans1;
}
else{
ans1 = dis[c1-1] - dis[c2-1];
ans2 = total - ans1;
}
if(ans1<ans2)
cout<<ans1<<endl;
else
cout<<ans2<<endl;
}
return 0;
}
总结
在输入数据的时候就计算每一步的边权之和,并且存储在数组dis[]种。